Support for Xiaomi Mi Router 4C (R4CM)

Hi @Jeffpeng i have same factory firmware as you, trid to install R4AC openwrt firmware, i keep getting verification failed, is there any trick to force it to accept it?

Hi @wzrigui
I guess you are trying to install the R4AC openwrt firmware through the factory firmware upgrade function. It will fail because you can only upgrade to the factory firmware. As I mentioned, you need the exploit to root log into the router first, and then upgrade it to openwrt with command.
And also notice, you will lose the WAN port function of R4CM because there's no perfect OpenWRT firmware for R4CM yet.

This thread work for my Mi Router 4C!!

I tried to flash Mi Nano firmware to Mi router 3C and its WAN port was behaving as LAN1 port and LAN1 as WAN, try to check if some LAN port is now a WAN.

That's great! Can you confirm that both WAN and LAN port works? How about Wi-Fi?
Also, are you using the Mi Nano firmware from the following link?


Aha, I see. You mean Xiaomi Router 3C, not 4C.
Thanks for your info. I am looking for a good OpenWRT firmware for my Xiaomi Router 4C.

Thanks to your suggestion, i ended up trying the method with invasion as said by @Jeffpeng and I was able to access with telnet and tried to flash with the firmware but it struggle on yellow led and I think its bricked now
Вот тут есть все что нужно

Can you please Post Closeup and clear photo of its board.

@xTomax @Jeffpeng
Hi. I have finally compiled a complete guide to loading openwrt on mi router 4c without opening it. But typing and explaining here is hell lot of work. Kindly install telegram and read my guide. WAN port works fine. Guide is written here. There are still minor bugs which we could fix to make the perfect rom. Looking forward to seeing you.

Kindly post your guide here in the forum, so that everybody can read it without having to install additional software.

Thanks! :slight_smile:

1 Like

Hi, I assume you have used this router for a while, I would like to know how was the performance, I am planning to buy this one.

Thanks in advance.

Any new updates?
How is the WAN issue?
Is there an specific firmware for the 4C?

does the device actually use all 4 antennas?
this has the same design as the 4a which is s dual band device and the 4a uses 2 antenna for each band.

so my isp is asking me to enable ddos protection. where can i find it can anybody suggest me?

I succeed installing Openwrt on R4CM with

I used openwrtInvasion to enable telnet working on firware 2.14.82 firmware of R4CM
A very good help came from Zorro

I used the Stable release of R4A

The steps I've followed
1/ have the routeur in routeur mode (not in AP)
2/ follow the video tuto of Zorro (except that I used Windows Powersheel with Debian bash instaed of his method of python on windows command)
3/ use the firmware above

Wan port is showing not connected but working

1 Like

How is the wifi signal?

No problems regarding connection and working condition. It's being used as an AP to provide internet access from a cabled intranet. But its not being put to test. 10 users usually connected at the same time, no major bandwith usage.

WAN is still not working (at all)