Support for TP-LINK TL-WN722N(v2)?


I've been following a tutorial at to try to turn a raspberry pi zero w and a TP-LINK TL-WN722N(v2) WiFi adapter into a vpn hotspot, for use with open networks when travelling.

the use of a semi non-standard "router" has posed a few issues, but I've gotten around and fixed them, and am now trying to set up my adapter. It is known to work well on raspbian, and I have in fact gotten it to work on my Pi 3B and 4B. I have an adequate power supply for it, and current draw should not be an issue. However, plugging it in sometimes triggers a restart. More importantly, despite installing "rtl8188eu-firmware" and the device showing up in lsusb, wlan1 isn't found if I run ifconfig.

I am not that much of a newbie with linux, but have managed to stay away from compiling drivers due to good support. However, this is only my second time using openWRT, so I am somewhat lost.

If someone could tell me why my adapter is not working and how to fix it, or even that it is not supported and to buy a new one, that would be great. however, I would ideally like to avoid buying an adapter with better support because I am short on cash and where's the fun in that?

Thank you in advance.

OpenWrt, targeted at devices with a handful of MB of storage, doesn’t install all drivers by default. Check what attaches with Raspbian or Debian or ... then install the needed driver with LuCI or

opkg update
opkg install kmod-blah-blah

I’d guess a Realtek driver of some flavor.

1 Like

Thank you for your help, but I still have some questions. I'm used to different command line tools, and have never used kmod before. Do you mean to put in the name of the driver, or a full URL?

Also, how do I tell once I get it working? Should ifconfig show wlan1?

Any help would be greatly appreciated.

opkg install <package name> will fetch it from the OpenWrt archives.

opkg with no args will give a usage message. Might need -h if I didn’t remember properly.

I’d check the boot logs to see if the driver picks up the device. If not, a quick check of the USB-related log messages or the sysfs entries to confirm that it was recognized at that level would be useful.

I’m old-school, but am slowly switching to ip link and the like from the Linux-based OS deprecated ifconfig. (Though I firmly consider systemd to be malware, in its literal definition.)

1 Like

You can use opkg list to see the list of available packages, after you run the update
The list is very long, so better narrow it down with | grep -i rtl

1 Like

Thank you guys so much! I'll have to wait until tonight before I have good WiFi, but I'll see what I can do on my lunch break today.

If finding the correct drivers fails, I'm planning on installing make and then using it to compile drivers from

Search the forum if you have to build the driver. There have been “varying degrees of success” with that. Realtek’s wireless drivers aren’t the most robust, from what I’ve read.


I've ran into some issues. I was repeatedly burning disk images to my SD Card while troubleshooting WiFi, but something seems to have changed. While using the exact same configurations file, suddenly the open SSID "OpenWrt" that I was previously able to connect to, I cannot. I am connecting from my chromebook, and it is throwing the error: failed to connect to network 'openWrt' : unrecognized error: not-authenticated. The pi also now shows wlan0 as being down, despite having the line option disabled '0' in my /config/wireless. When i run ifconfig wlan0 up the output is [ 543.509083] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

The only reason I can see for this is that I somehow fried the WiFi module, either in software or maybe with ESD?

I am super confused as I thought that these devices were more resilient than this, so I am hoping someone can tell me what these error messages mean.

edit: tried to connect to openWrt at home and had no issues. Very strange.

I've fixed my issues, and am back to trying to install rtl8188eus drivers. I have installed rtl8188eu drivers but they do not work, or if they do I cannot tell.

I have found a driver at, and just need to install it. Could someone help with that?

I've gotten to make all but even after some troubleshooting I get root@OpenWrt:/rtl8188eus# make all /bin/sh: cc: not found (standard_in) 1: syntax error make ARCH=armv6l CROSS_COMPILE= -C /lib/modules/4.9.184/build M=/rtl8188eus modules make[1]: *** /lib/modules/4.9.184/build: No such file or directory. Stop. make: *** [Makefile:1911: modules] Error 2