Support for TP-Link Archer C60 v.2

TP-Link Archer C60 v.2 listed as supported device, but when trying to upgrade through original WEB UI tells: Invalid file type
for both:

Original firmware release: 2.0.0 Build 20170117 rel.41431

1 Like

If flashing from Webinterface does not work, checkout the other instructions from the commit message...;a=commit;h=c0742307a18178ee7d2cee1fc6b0e199ccb1e1fa

TFTP method does not work too....

I see in tftp server log file request from router
Waiting about 5 minutes
Power off/Power on

And original firmware at it own place

Does using 17.01.4 first work?

I don't see 17.01.4 for TP-Link Archer C60 v.2.

Only for Archer C5 and C7

How about .5?

And where do you see archer c60 at this link???

1 Like

My apologies. C60!!!

Did you rename the file tp_recovery.bin?

There will happen no backports of devices...
C60v2 commit is from Jan 2018 and therefore no 17.01 image.

Try to find an older stock image and try web and tft recovery.
If this does not work, you have to use serial connection and a manual flash with u-boot.

1 Like

Yes of course i renamed file to tp_recovery.bin
And even tried to write older stock firmware(TFTP), but nothing.

I use tftpd-hpa in verbose mode and in /var/log/syslog/ observer file tp_recovery.bin request from router.

But still nothing.

P.S. I'm already bricked one Archer 60 v2 through UART - set wrong offset in U-boot when write to flash.
And case opens very hard, in previous one broke some clips.

Bad thing with wrong offset, but is only a softbrick...

If you write a older stock fw with tftp, the bootloader gets not downgraded if you used a fw with boot in the name.
Only from the stock web interface the bootloader of the stock fw gets written to flash.

Please provide a serial log of tftp recovery if you solder a serial header.
Would be interesting why it didn´t work...

UART logs:

Normal boot log

Boot log with reset button pressed
Original file name: openwrt-18.06.0-ar71xx-generic-archer-c60-v2-squashfs-factory.bin renamed to tp_recovery.bin

Boot log with resset button pressed.
Original file name: ArcherC60v2_un-up-ver2-0-0-P1[20161206-rel60287].bin renamed to tp_recovery.bin

After last string log

Stack Pointer at: 7df67f98

system halting

The following lines appear three times each time.

Aug 11 01:46:41 gws in.tftpd[31145]: RRQ from filename tp_recovery.bin
Aug 11 01:46:44 gws in.tftpd[31156]: RRQ from filename tp_recovery.bin
Aug 11 01:46:47 gws in.tftpd[31160]: RRQ from filename tp_recovery.bin

But I release the reset button immediately after the first line appears in the tftpd log

TFTP server 100% works!
Because i tried in U-boot
U-boot log

P.S. Connected WAN and LAN port 1 interfaces.

Manual load throught TFTP ...sysupgrade.bin

And know I can erase and write to flash but I do not know right offset?

Next string looks very strange to me

bootcmd=go 0x80010000

As I read in U-boot manual go command in bootcmd script should used only for windows images.
For linux images should benn used bootm command.
And why this address in memory, in another TP-link routers this is adress in flash

Bad thing with wrong offset, but is only a softbrick...

There is a way to recovery U-Boot if PCB has no JTAG???
I thought that U-Boot initialize UART serial console and if U-boot is dead - router bricked forever???

Am I wrong??

Seems there is something broken in tftp recovery :hushed:
The commit message of c60v2 does say the exact commands to use for manual flashing:

tftp 0x81000000 lede-ar71xx-...-sysupgrade.bin
erase 0x9f030000 +$filesize
cp.b $fileaddr 0x9f030000 $filesize

The address 0x9f030000 is the offset where your stock firmware gets booted in your log and should therefore be correct.

As i know the atheros u-boot versions does not use the bootcmd environment and does start the image directly as c code with bootm in there board files... Don´t get confused about the not used environment variable. The bootcmd go 0x80010000 does jump directly to the first instruction in ram address 0x80010000 and is probably used to start a chainloaded bootloader.

For recovery you can use flashrom, a spi programmer and a flash clip:
USB Programmer CH341A
Soic8 Sop8 Flash Chip

On my more powered devices as WDR3600, WR1043v3 and etc i can read and flash the spi nor flash without desoldering.
As you have a second device, you could clone that device and change only the mac address if needed.

One addition to recovery, also if you have overwritten you spi flash. Before you overwrite it again with flashrom, do a backup anyways.
Probably you could need it or restore only the other config, wlan calibrantion data if that are not overwritten.

For the best case, you should only clone the bootloader and use the other stuff from your original backup if they are okay.

Thank You!!

Sucessfuly wirted!

tftp 0x80060000 openwrt-18.06.0-ar71xx-generic-archer-c60-v2-squashfs-sysupgrade.bin
erase 0x9f030000 +$filesize
cp.b $fileaddr 0x9f030000 $filesize
run bootcmd

P.S. I already haven't softbricked device so haven't ability to try your solution for U-boot recovery, but thanks too. I will know for future cases.

As I say: all people are divided into two categories

  1. Who does not make the backup copy.
  2. And those who are already do it.

I'm one of those people who are already do backups. :grin:

I even added topic Create Full MTD Backup from router in Generic Backup wiki at


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.