Support for TL-WR840N(ES) Ver 5.0 (EU)


#264

r u that geisha from phil


#265

@pradorocchi
i would like to build a firmware on it with openvpn, dear sir can you spare me some link...to do so


#266

Hi robi, I want to ask how to create header image on wr840nv5 ? I look your lede build with hex editor, the header different with stock firmware but it can accept by tp-link upgrade menu. I was success build stock firmware with activate all modes build with gpl code, but it not contain header like stok tp-link firmware. I need your help to test my firmware too. Please, contact me by message. Thanks.


#268

Finally I found a way to install OpenWRT on the WR840N V5.
The latest sysupdate provided by pradorocchi doesn't save the configuration after rebooting the router, so it's useless.
I used Chef Imagebuilder (https://chef.libremesh.org/) and created an image without all the ipv6 stuff and ppp, the image file is ~3.5MB.
First I used robimarko's TFTP image (no luci) and installed it via tftpd64. Then I've connected to the router via PuTTy (SSH) and pushed the sysupdate file to /tmp. Everything works well for now.


#269

Could someone please re-post the link to the image that can be used to switch to openwrt/lede directly from the TP-Link web interface firmware upgrade menu? There were just too many images posted, it is not clear which one to use
From there I'll be able to sysupgrade to my own built image.
Thank you!


#270

Ok, I managed to install.
Is the wifi working for anybody here? I installed the general Openwrt trunk build, and also created a custom image from the 18.06 branch, but wlan is not working at all. Logread does not show any errors, it looks like the interface is up.
But most of the time the SSID is not even visible to my client devices, and even if it is for some seconds, connection is not possible to the network.


#271

Anyone there try to change the 25Q32 from TL-WR840N(V5) to SPI flash 25Q64 with TL-WR840N(V4) firmware?...


#272

Hi, I have this kind of version but regional is RU. I would be glad if anyone can help me to upgrade it. Unfortunately i did not find anything useful with (RU)


#273

I also had the same idea but while removing the 32 chip I accidently removed this resistor "R74".
If someone could check the rating of this resistor then it will be easy for me.

https://filebin.net/bu7jmdpdhxmysjbj


#274

So small resistor...
Hope you can fix it soon...
In indonesia,there is someone was success with the idea...
This is the link...


#275

can someone please tell me what value Pull up resistor should I use on R74 .Chip pin 7


#276

My multimeter says R74 has ~10 kOhm


#277

ok thank you


#278

A post was merged into an existing topic: Support for TL-WR840N Ver 6.0


#279

I install a Openwrt 18.06.0 and 18.06.1 from release files, but doesn't safe configuration after rebooting.
Anyone have the solution for this?


#280

We had this problem of losing the previous configuration because the space left over to make the overlay filesystem shrank. So it seems that at least its first part gets overwritten, therefore making the data unreadable. The workaround is simple, saving the overlay partition (/overlay) before update (using tar or copy -aR to /tmp and scp to another system) and writing back the configuration files (mostly /etc/config) after update. It is more work than just running update, but if you configuration is complex it is worth it. Otherwise it may be simpler reconfiguring by hand after update.

S.


#281

I'm trying to flash the tftp-recovery.bin file to my WR840N(ES) V5 router via tftp from a linux laptop. It takes the file from my laptop:
"in.tftpd[3487]: RRQ from 192.168.0.2 filename tp_recovery.bin"
flashes with green light for a second and then just reboots back to stock firmware :frowning: .

Am I doing something wrong? I still don't have a USB=>Serial adapter (will buy one soon) to see what is wrong on the flashing process but when I try to flash sysupgrade.bin in web gui I get error: "71211"41796669_257163524945759_1823181422077149184_n


#282

Untitled

I have strange terminal characters when I connect to serial port, any help?


#283

That's usually a sign of bad GND connectivity.


#284

I tried resoldering and still get weird characters, looks like a boot process but the data is all weird chars. Now I'm hitting max post and max image attachment limits... 41782966_2245080375759940_4991040701358669824_n