Support for Powerbeam M5-300 in ath79 target?

Hi everyone,
I own a pair of old Powerbeam M5-300, which currently run with the OEM firmware. According to the wiki, there is support for them in OpenWrt 19.07.10 [1], which is the old ar71xx target, but no newer version. Altough I found this commit [2], which states, that it brought back support for the Powerbeam M XW devices for the ath79 target. As the Powerbeam M2-400 and M5-400 has firmware links in the wiki to the current release and the M5-300 not, I'm a wondering why not. Is it just not tested by someone yet and should work in theory? My M5-300 run the XW firmware from Ubiquiti, so they are definitly XW hardware, so in my understanding they should be supported by this commit, but I don't want to brick them. Can someone confirm this? If yes, I will flash them (with 22.03.5, because I read there is a bug in 23.05.0, loosing configuration with some Ubiquiti devices) and edit the wiki.


the two device should be the same, only the dish have a different size.

Just in general, the porting from ar71xx to ath79 is a manual task. Someone with the device on their desk has to do the necessary development, test it and then submit the changes to OpenWrt (not unlike adding a completely new device, except that quite a few of the development steps are a tad easier, as the device and many of its characteristics are 'known' already). While that succeeded for a large part of the devices previously supported by ar71xx, not every device was so lucky to have owners doing the necessary development work. Support for those devices went away with the ar71xx target and is no longer available - that does not preclude them from being added to ath79 again, if someone can provide the required patches,

For now I can say the the M5-300 isn't working with OpenWRT. Neither with the old ar71xx target (19.07.10) nor with the ath79 target. First I tried to install 22.05 via the Webinterface. It looked like it worked, but I can't get any network connection via the ethernet port. At least tftp recovery worked, so I tried 19.07.10, but I got the same result. So I flashed it back to the stock firmware and the device is working again. Maybe it's an ethernet bug? The wiki says:

It seems so that the XW Ethernetbug is not present in the Powerbeams.

Does anyone know what this mean? Maybe it's worth compiling my own image with a preconfigured Accesspoint so I can try to login without destroying the case?

I got it somehow working, but with the nanobeam-m5-xw image. It seems that the ethernet has some problems. When the link goes down, dnsmasq fails and I can't get any IP via DHCP. All this changed when I connected it to a dumb 100Mbit/s switch, so the link won't go down. In the next days I will test this with the powerbeam image and my second Powerbeam.

1 Like