Support for Mikrotik wAP 60G

Hi, I am a little bit lost when it comes to build a new openwrt image for a new device. I have recently purchased a Mikrotik wAP 60G (https://mikrotik.com/product/wap_60g), and no matter what things I have tried it does not boot the initramfs of openwrt, I was wondering if anyone could help me. As far as I know, this is the first time somebody wants to port openwrt to an ARM version of a Mikrotik device.

This is all I can do/know:

  • There are other openwrt for other Mikrotik devices but they don't use the ARM processor.
  • I can root the device, but I am still unable to do something useful with it.
  • The build I tried was for a generic Q40xx (since the processor is IPQ-4019 ) and, although the device does request the file through TFTP, it just boots into the normal RouterOS at some point.
  • I have the "latest" kernel patches for the 3.3.5 kernel that Mikrotik uses, but they are too old and I still don't know how to upload my custom kernel to the device.

A few questions:

  • Is it possible for me to take one of the Mikrotik builds for other architectures and build them for ARMv7? If so, is there any documentation in this regard?
  • Would it be easier to try to compile something for the IPQ-4019 processor and then apply the changes for Mikrotik?

Also, this is the first few lines of the dmesg command in case this gives any extra info:

Booting Linux on physical CPU 0
Linux version 3.3.5 (build@builder) (gcc version 4.8.2 (GCC) ) #2 SMP Wed Feb 28 10:26:17 UTC 2018
CPU: ARMv7 Processor [410fc075] revision 5 (ARMv7), cr=10c5387d
CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
Machine: Qualcomm (Flattened Device Tree), model: LHG 5HnD60ad
Memory policy: ECC disabled, Data cache writealloc
On node 0 totalpages: 65536
free_area_init_node: node 0, pgdat 8044d340, node_mem_map 80474000
  Normal zone: 512 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 65024 pages, LIFO batch:15
PERCPU: Embedded 13 pages/cpu @80684000 s5312 r32768 d15168 u53248
pcpu-alloc: s5312 r32768 d15168 u53248 alloc=13*4096
pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3 
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 65024
Kernel command line: root=/dev/ram0 bootimage=1 no-uart no-nand parts=1 boot_part_size=16777216 eth_mac=CC:2D:E0:AF:24:9E board=lhg60-dk Board=lhg60-dk ver=6.41.2 hw_opt=00284401 boot=1 mlc=11
PID hash table entries: 1024 (order: 0, 4096 bytes)
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 256MB = 256MB total
Memory: 238540k/238540k available, 23604k reserved, 0K highmem
Virtual kernel memory layout:
    vector  : 0xffff0000 - 0xffff1000   (   4 kB)
    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)
    vmalloc : 0x90800000 - 0xff000000   (1768 MB)
    lowmem  : 0x80000000 - 0x90000000   ( 256 MB)
    modules : 0x7f000000 - 0x80000000   (  16 MB)
      .text : 0x80008000 - 0x803dfc08   (3936 kB)
      .init : 0x803e0000 - 0x804124c0   ( 202 kB)
      .data : 0x80414000 - 0x8044f1e0   ( 237 kB)
       .bss : 0x8044f2c8 - 0x8047312c   ( 144 kB)
1 Like

Can u tell me how to root the device?

You could use a modded kernel cpio like I do and package init in it to start telnet and install full busybox.
Thanks to adron who figured it out when we were struggling with Mikrotik and ipq40xx

1 Like

Hi PolynomiallDivision, this https://github.com/robimarko/openwrt/tree/LHGG-60ad-PR works directly with the wAP 60G.

Just follow the instructions and you will have root access on your device :slight_smile:

1 Like

Maybe a dump question. Which instructions? I compiled the image for the target. Can I just flash it via routeros? I'm a bit scared bricking the device. I think the image is for the dish version?

Nice. Thanks.