One further question: I keep reading that using a second CPU core on that architecture prevents the use of the telephony ports. How do the original vendors of the hardware (including O2 6431 or AVM Fritzbox 7412 or 7490) do it? They clearly support the telephony ports, and their setup supports throughput (with NAT) of 100 Mbit/s. Do they make use of SMP, or is there a different trick to get support for 100 Mbit/s?
According to my info's, OpenWRT 20.x will be based
on the longterm kernel 5.4.
This is supported until Dec, 2025.
While OpenWRT 19.07 used the kernel 4.14,
the kernel 4.19 was used in the development tree
until mid-June 2020.
The last 4.19 version was 4.19.123, followed by 5.4.46.
The now uploaded snapshot with kernel 5.4.59 is a
QA version. Because 20.x is still
in development.
I don't have an xDSL line. I use port DSL as WAN for internet connection. My config:
config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'
option ipv6 '0'
option metric '20'
option auto '1'
config device 'wan_dev'
option name 'eth0.2'
option macaddr '5c:cf:69:12:6f:13'
option ipv6 '0'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'
It's not working with new kernel 5.4. Interface eth0.2 isn't picking address from DHCP. I have no idea what's wrong.
Thanks in advance for suggestions!
my network configuration is this
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd56:3b33:95f4::/48'
config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option nameprefix 'dsl'
config dsl 'dsl'
option annex 'b'
option tone 'av'
config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
list ifname 'eth0.1'
list ifname 'eth0.66'
config device 'lan_eth0_1_dev'
option name 'eth0.1'
option macaddr 'd4:63:fe:01:cb:c4'
config interface 'wan'
option ifname 'dsl0'
option proto 'pppoe'
option username 'username'
option password 'password'
option ipv6 '1'
config device 'wan_dsl0_dev'
option name 'dsl0'
option macaddr 'd4:63:fe:01:cb:c5'
config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'
config switch
option name 'switch1'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch1'
option vlan '1'
option ports '0 1 2 3 6t'
config device 'inic_dev'
option name 'eth0.3'
config interface 'inic'
option proto 'none'
option ifname 'eth0.3'
config switch_vlan
option device 'switch0'
option vlan '3'
option vid '3'
option fid '3'
option ports '5 6t'
config device 'wlan_dev'
option name 'eth0.66'
config device 'guest_wlan_dev'
option name 'eth0.71'
config switch_vlan
option device 'switch0'
option vlan '4'
option vid '66'
option fid '4'
option ports '5t 6t'
config switch_vlan
option device 'switch0'
option vlan '5'
option vid '71'
option fid '5'
option ports '5t 6t'
it can also be found via the link above.
While wifi cannot be configured via luci,
this is definitely possible with WAN.
It's certainly not necessary to reboot.
Enable 5 GHz wireless:
uci set wireless.wl000.disabled='0'
uci set wireless.default_wl000.disabled='0'
uci commit wireless
wifi up
Enable 2.4 GHz wireless:
uci set wireless.wl010.disabled='0'
uci set wireless.default_wl010.disabled='0'
uci commit wireless
wifi up
Disable 5 GHz wireless:
uci set wireless.wl000.disabled='1'
uci set wireless.default_wl000.disabled='1'
uci commit wireless
wifi down
Disable 2.4 GHz wireless:
uci set wireless.wl010.disabled='1'
uci set wireless.default_wl010.disabled='1'
uci commit wireless
wifi down
Has anyone tested Easybox 904 with Annex A?
The VDSL modem is directly connected to the DSL port, it can only used for that and doesn't speak ethernet (mis-connecting it to ethernet devices might cause permanent hardware damage).
If you want to use the eb904 as plain wired (ethernet-) router, you must redefine one of its LAN ports for WAN (which is slightly complicated because of the very specific two-stage switch/ VLAN setup with its inherent expectations, but possible).
@slh
I'm using DSL port as WAN, work fine in kernel 4.19... Only kernel 5.4 has a strange problem. Vlan for DSL port is not working.
@slh In general you are right, but in case of EB904xdsl, there are several relays on the board, which can physically switch two wires from DSL/WAN connector between ETH1000, DSL and ISDN modems. Additionally, these switches control which HW filter is enabled according to Annex settings, and what is connected to POT outputs: input POT line in case of Annex A/L/M, or SLIC voice outputs, in case of Annex B/I/J or WAN.
This means, that to the DSL/WAN port on the EB904xdsl, at the same time could be connected:
- Ethernet 1000BASE-T (also known as IEEE 802.3ab) - uses 4 pairs of wire
- Ethernet 100BASE-TX (also known as IEEE 802.3u) + xDSL Annex A/B/I/J/L/M - uses 2 + 1 pairs of wire
- Ethernet 100BASE-TX (also known as IEEE 802.3u) - uses 2 pairs of wire
- xDSL - uses only 1 pair of wires
I think some other DSL routers also have a DSL/ethernet combo port which can be used either as DSL port or as an ethernet switch port. If I recall correctly the O2 box 6431 works that way (using OpenWRT).
@gschwarz yes, you are right. But difference is in maximal speed - O2 box 6431 supports only 100Mbs on the any port.
DSL works fine with the 5.4.59 build (I use dsl0.7 on WAN, because my ISP requires VLAN tagged DSL frames). /etc/init.d/dsl_control does not have any execute bits set though, I chmod a+x'd it. Is this on purpose?
thanks for test and feedback. no that is not on purpose.
the file /etc/init.d/dsl_control had to be built into the imge with the imagebuilder and
the argument "FILES =".
otherwise will
/lib/functions/lantiq_dsl.sh
not found and you get an error building the image. I just overlooked the fact that the file is so on my disk.
this will be corrected with the next snapshot.
I had a closer look at the default wifi config, which reads:
wireless.wl000=wifi-device
wireless.wl000.type='ralink'
wireless.wl000.channel='11'
wireless.default_wl000=wifi-iface
wireless.default_wl000.device='wl000'
wireless.default_wl000.network='lan'
wireless.default_wl000.mode='ap'
wireless.default_wl000.ssid='easybox'
wireless.default_wl000.encryption='psk2+aes'
wireless.default_wl000.key='WiFipassword'
wireless.wl010=wifi-device
wireless.wl010.type='ralink'
wireless.wl010.channel='11'
wireless.default_wl010=wifi-iface
wireless.default_wl010.device='wl010'
wireless.default_wl010.network='lan'
wireless.default_wl010.mode='ap'
wireless.default_wl010.ssid='easybox'
wireless.default_wl010.encryption='psk2+aes'
wireless.default_wl010.key='WiFipassword'
wireless.wl001=wifi-device
wireless.wl001.type='ralink'
wireless.wl001.channel='6'
wireless.default_wl001=wifi-iface
wireless.default_wl001.device='wl001'
wireless.default_wl001.network='lan'
wireless.default_wl001.mode='ap'
wireless.default_wl001.ssid='easybox-guest'
wireless.default_wl001.encryption='psk2+aes'
wireless.default_wl001.key='WiFipassword'
wireless.wl011=wifi-device
wireless.wl011.type='ralink'
wireless.wl011.channel='6'
wireless.default_wl011=wifi-iface
wireless.default_wl011.device='wl011'
wireless.default_wl011.network='lan'
wireless.default_wl011.mode='ap'
wireless.default_wl011.ssid='easybox-guest'
wireless.default_wl011.encryption='psk2+aes'
wireless.default_wl011.key='WiFipassword'
This results in four Wifi networks:
On 2.4 GHz channel 6 easybox and easybox-guest, whose MAC addresses have an OUI of D4:63:FE ( Arcadyan Corporation) and differ only in the last bit, i.e. looks fine.
On 5 GHz however, the two networks (easybox and easybox-guest) are on channel 36, and the two MAC addresses differ in the OUI only, the first one correctly being D4:63:FE, but the second one D2:63:FE.
Is this a bug in the driver, i.e. is the wrong octet's bit has been flipped?
Also, why channel 36? To me the configuration is a bit strange to start with. Can wl010 (i.e. the 5 GHz interface) be set to channel 11 or 6? Also, can wl001 be set to a different channel than wl000 (apparently not, and that's why the 11 setting is overwritten by the latter 11 setting for the 2.4 GHz interface). Similar issue for the two 5 GHz interfaces, which of course end up using the same channel (what other chance do they have...). But why is that channel 36? Does setting a 5 GHz interface to channel 6 result in channel 36? Is this a proper configuration?
Is there a chance to have OpenWRT support any of the remaining hardware features of the 904 xdsl?
There's a "WiFi/WPS" switch, there's an internal S0 ISDN bus, and there's a built-in chip cardreader.
The latter one is probably not supported even by the original firmware (which to my knowledge is based on an older release of OpenWRT), but the first two features are, so in principle it should be possible to figure out how it is being done.
https://www.randomprojects.org/wiki/Vodafone_EasyBox_904_xDSL lists some hardware info and claims the ISDN chip to be some Infineon chip.
The wifi configuration in /etc/config/wireless should only be an example.
It was assumed that the file was adapted to its own environment
(e.g. SSID, password, channels). If the wireless file is edited on the
command line with nano or vi and then started with "wifi up" or "wifi reload",
they are not accepted.
So far I could only limit it to 2.4GHz easybox and easybox-guest
who stay at channel 6.
when I look at the mac addresses with ifconfig I see D6:63:FE at wl001.
D2:63:FE, I can't see it on the box.
Chip card readers or WPS buttons were never on the to-do list as far as I know.
The support for all functions would not be possible.
Even if the Vodafone firmware is based on OpenWRT, it is a closed system
and no new version has been released since 2018.
Maybe it's a bad example but take Apple Macs with MacOS and
Linux with x86/x64 architecture.
The situation is similar with Fritzbox, Easybox and OpenWRT.
On the one hand closed systems and open ones like Linux and OpenWRT.
For the S0 ISDN Bus I recommend a look at the VPE image in
which Asterisk16 is also there.
**New images with kernel 5.4.60 [VPE & SMP] **
----------------------------------------------------------------
OpenWrt 19.07 SNAPSHOT / Kernel 5.4.60 / xDSL-VoIP-GSM Gateway
----------------------------------------------------------------
| Machine: Easybox 904xDSL |
| Uptime: 0d, 04:02:01 |
| Load: 0.01 0.00 0.00 |
| Flash: total: 251.9MB, free: 246.1MB, used: 0% |
| Memory: total: 106.5MB, free: 65.5MB, used: 38% |
| Leases: 1 |
| lan: static, 192.168.1.1 |
| inic: none, no IP address |
| hilink: dhcp, no IP address |
| upcwifree: dhcp, no IP address |
| wwan: dhcp, no IP address |
| umts: 3g, no IP address |
| PPTP: pptp, no IP address |
| TUN: none, no IP address |
| wg0: wireguard, no IP address |
| ipsec: none, no IP address |
| NCM: ncm, no IP address |
| wan: dhcp, 192.168.0.2 |
----------------------------------------------------------------
asterisk -V
Asterisk 16.10.0
-------------------------------------------------------
OpenWrt 19.07 SNAPSHOT / Kernel SMP 5.4.60 / xDSL-WAN
-------------------------------------------------------
| Machine: Easybox 904xDSL |
| Uptime: 0d, 00:03:20 |
| Load: 0.75 0.81 0.36 |
| Flash: total: 247.0MB, free: 242.1MB, used: 0% |
| Memory: total: 118.4MB, free: 72.8MB, used: 38% |
| Leases: 0 |
| lan: static, 192.168.1.1 |
| inic: none, no IP address |
| hilink: dhcp, no IP address |
| upcwifree: dhcp, no IP address |
| wwan: dhcp, no IP address |
| umts: 3g, no IP address |
| PPTP: pptp, no IP address |
| TUN: none, no IP address |
| wg0: wireguard, no IP address |
| ipsec: none, no IP address |
| NCM: ncm, no IP address |
| wan: dhcp, 192.168.0.17 |
-------------------------------------------------------
Luci (en, de, pl) and some useful commands in System => Custom Commands.
LCD (two themes available), touchkeys, 3G/LTE modems, filesystem: exfat, ext4, vfat, msdos, f2fs, nfs, ntfs.
Software: Asterisk (image VPE) Adblock, DDNS, Disk Man, Htop, Midnight Commander (with mouse), Mtr, Nano, Nlbwmon, N2N, NFS, QoS, OpenVPN, Picocom, Stubby, Wireguard, 3GInfo, Sysinfo, SMS-Tool, Tcpdump-mini.
All packages are available in the online repository.
=> OpenWrt 19.07 full VPE version with Asterisk
=> OpenWrt 19.07 full SMP version
Click on the button "Pobierz". The download is free and safe:
https://www.virustotal.com/gui/file/6ee5df480a76fa6857be51751bae661c74b2af6c7c6a70fd72bf097cab96ee6b/detection
https://www.virustotal.com/gui/file/0f99be2c065d503a2533e0ec83866bb0629f424cc8a8fcffd641fc4e23b400e1/detection
Edit:
https://github.com/zuzia-dev/Easybox-904xDSL/blob/master/openwrt-lantiq-xrx200-arcadyan_vgv952cjw33-e-ir-smp-squashfs-sysupgrade.bin
https://github.com/zuzia-dev/Easybox-904xDSL/blob/master/openwrt-lantiq-xrx200-arcadyan_vgv952cjw33-e-ir-vpe-squashfs-sysupgrade.bin
You are right, when I look at the MACs with ifconfig, I also see D6:63:FE for wl001. The last octet of the MAC is the same one as wl000's. To me this is a bug. The two MACs should differ in the last octet, not the first one of the MAC. wl000, wl010, and wl011 look OK with ifconfig.
However, when I look at the WiFi networks available (using an AVM Fritzbox next to the Easybox as a scanner) the entries (incl. MACs) for the two 2.4 GHz networks look OK, whereas the easybox-guest network on 5 GHz has a MAC starting on D2:63:FE, as described above. To me there's definitely something wrong with the driver which leads to an incorrect MAC to be used and to be displayed for wl001. Is this driver specific to/patched for the 904, or is this an unmodified Linux driver?
BTW, 36 seems to be the channel the 5 GHz wifi defaults to when some illegal channel number is configured.
I confirm that the MAC addresses are incorrect.
#WiFi 5 GHz
config wifi-device 'wl000'
option type 'ralink'
option channel '36'
option legacy_rates '0'
option htmode 'VHT40'
option disabled '1'
config wifi-iface 'default_wl000'
option device 'wl000'
option mode 'ap'
option ssid 'EasyBOX'
option encryption 'psk2+aes'
option key 'WiFipassword'
option network 'lan'
option disabled '1'
#WiFi 2.4 GHz
config wifi-device 'wl010'
option type 'ralink'
option channel '11'
option legacy_rates '0'
option htmode 'VHT40'
option disabled '1'
config wifi-iface 'default_wl010'
option device 'wl010'
option mode 'ap'
option ssid 'EasyBOX1'
option encryption 'psk2+aes'
option key 'WiFipassword'
option network 'lan'
option disabled '1'
# WiFi dla gościa 5 GHz
config wifi-device 'wl001'
option type 'ralink'
option channel '36'
option legacy_rates '0'
option htmode 'VHT40'
option disabled '1'
config wifi-iface 'default_wl001'
option device 'wl001'
option network 'lan'
option mode 'ap'
option ssid 'EasyBOX-guest'
option encryption 'psk2+aes'
option key 'WiFipassword'
option disabled '1'
# WiFi dla gościa 2.4 GHz
config wifi-device 'wl011'
option type 'ralink'
option channel '11'
option legacy_rates '0'
option htmode 'VHT40'
option disabled '1'
config wifi-iface 'default_wl011'
option device 'wl011'
option network 'lan'
option mode 'ap'
option ssid 'EasyBOX1-guest'
option encryption 'psk2+aes'
option key 'WiFipassword'
option disabled '1'
wl000 Link encap:Ethernet HWaddr 9C:80:DF:63:F9:E4
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
wl001 Link encap:Ethernet HWaddr 9E:80:DF:63:F9:E4
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
wl010 Link encap:Ethernet HWaddr 9C:80:DF:63:F9:E6
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
wl011 Link encap:Ethernet HWaddr 9C:80:DF:63:F9:E7
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
I'm currently trying out that image. It appears that the MAC addresses cannot be properly established:
root@EasyBOX: ~$ ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:11:22:33:44:55