Support for Easybox 904 LTE

Despite the title, this thread is more about the xDSL variant and not the LTE device. While the xDSL variant is mostly supported out-of-tree (as there are considerable difficulties to support it in a way that doesn't break other lantiq devices), there hasn't been a lot of development for the LTE variant so far.

Thanks for the hints. With the 3.07 image's SQL Injection-type of bug I was able to activate telnetd and perform the necessary settings (https://router-kaufen.com/vodafone-easybox-904-lte-fuer-andere-provider-zugaenglich-machen/ and https://www.home-network.org/projekte/easybox-904 provide good tutorials).
Network traffic works nicely.
Now does the 904LTE also support voice telephony via 2G or 3G (not via VoIP)? A quick trial suggests it doesn't, but maybe there's a trick to activate it?

Hello. What happened to your site with software?

Hey,
I got a 940 for free and tried to install openWRT. unfortunatly I failed getting the Boox to download the iso over tftp server. I tried both my Windows and my ubuntu Laptops. has anyone a clue?
Is ther a better way?
Gratings from Erlangen
Axel
Ps.: ( I'd like to try to ad an usb lte Card and later maybe use it for freifunk...)

hey Axel,

try to look for this page:

Lantiq XRX200 Easybox 904xDSL and Speedport W 921v build

and this file:

eb904x.tar.xz

maybe this will help

My site is now available:
https://chomikuj.pl/ZuzannaCK/ROUTERY/EASYBOX+904+xDSL

New snapshots:
=> OpenWrt (kernel 5.4.116 VPE) - Easybox 904 xDSL (github)

Backup link => Click on the button "Pobierz" (file openwrt-lantiq-xrx200-arcadyan_vgv952cjw33-e-ir-vpe-squashfs-sysupgrade.bin)
The download is free.

=> OpenWrt (kernel 5.4.116 SMP) - Easybox 904 xDSL (github)

Backup link => Click on the button "Pobierz" (file openwrt-lantiq-xrx200-arcadyan_vgv952cjw33-e-ir-smp-squashfs-sysupgrade.bin)
The download is free.

=> Perform the following procedures to upgrade the firmware.

1 Like

If there hope for getting the wifi working beyond ap? I just want it to turn it into a wifi repeater. If this is already possible what am i not seeing? If this is a stupid comment then i apologize in advance.

Wow, great that you made new builds, thank you for your effort! This time I installed SMP-build successfully (the previous version did not boot).

Is DSL port used as WAN limited to 100 Mbit/s, or there are options?

If xDSL is active, router not getting gigabit speed on WAN. If you are using the WAN (over ethernet), remove xDSL support:

opkg remove dsl-vrx200-firmware-xdsl-a dsl-vrx200-firmware-xdsl-a-patch \
dsl-vrx200-firmware-xdsl-b dsl-vrx200-firmware-xdsl-b-patch \
kmod-ltq-vdsl-vr9  ltq-vdsl-app ltq-vdsl-mei_test \
ltq-vdsl-vr9-vectoring-fw-installer atm-esi kmod-atm kmod-ltq-atm-vr9 \
kmod-ltq-ptm-vr9 linux-atm br2684ctl kmod-pppoa ppp-mod-pppoa kmod-atmtcp \
atm-diagnostics kmod-ltq-vdsl-vr9-mei --force-depends

Reboot your router.

1 Like

can someone advise me a little how to update Easybox 904 LTE to openwrt.
I have read a lot, but i'm unable to install openwrt. Im lost where to find a working fullimage.img for the LTE Version. I have managed to setup a tftpd and have download a fullimage.img from renericas post. but after writing the File, the router hangs in boot loop. Im still able to load images from TFTP, but i can´t find the right fullimage.img. Any tips whrere to search ? thanks a lot The current Image offered by vodefone can´t be installed with message wrong image.

Despite the name of this thread, it's mostly about the xDSL variant - and while similar, no one has really worked (to completion) on the LTE variant so far. So at this moment, the LTE hardware variant is not supported at all (and technically neither is the xDSL variant, as it needs considerable unmerged/ external patches to work <-- but at least those do exist, while they don't exist for the LTE variant).

thank you for your quick response ;-). looks like i have a new paperweight. ;-(

Can someone provide a link to a recovery image ? Tftp is possible, but no image is accepted. Thanks vossi

You probably will have to set up serial, to find out why they're not accepted.

I can help. If you give me your email address.

spammaddress@outlook.de

serial converter will arrive tomorrow ! Let's see what we can figure out.

Reiner

Hi everybody,

I'm trying to run my own builds, but the box does no accept the recovery/kernel. If I do a sysupgrade, the box is stuck during boot.
I never had problems with the images provided by Zuzia, thus probably I have some mistake during building.

Is there any help?

To be specific and start from the start, should I start with the fork of QAuge, or the (newer) one from Plonk34? If the latter, I tried the branches xrx200-1 and xrx200-3.
Depending on the source, should I use the default config or choose the appropriate Target/Device?
Which packages need to be included, if not included by default?
Are there additional steps, apart from make some-config and compile-building via make?

Thanks and Thanks for the work done so far!

1 Like

my box was a LTE Version. TFTP recover with Image from Zuzia worked like a charm, and restored my box succesfully.

Hello,
thanks for the effort all, so far.

Unfortunately the newest VPE image from Zuzia does not provide the ability to connect Guest Wifi.
The network can be set up but clients cannot receive IP addresses.

I have tried everything and every guide, firewall off and on, firewall trafic exceptions for DNS and DHCP ports added, none works, no IP address for guests. Again, SSID and authentication works, but no DHCP and gateway.

Before anyone challenges me to post my firewall config, I challenge you to bring up the Wifi guest network actually, as no one actually did it in this thread (everyone has vlan 71 or guest interface commented out), and post how. I suspect it is an error in the Zuzia image or kernel. I wonder if the Plonk image works.

Any help is appreciated.