Support for Easybox 904 LTE

With kernel 4.19 or 5.4?

I'm not exactly sure what you're up to, but if all you want to do for the time being is to play around with your Easybox, I recommend the following setup:

Configure your main router's LAN to 192.168.1/24, the router's own LAN IP to something like 192.168.1.3 (not 192.168.1.1) and the router's DHCP range to some portion out of 192.168.1/24 higher than the router's LAN IP.
Now you can connect your OpenWRT router via LAN cable using its standard static LAN IP address of 192.168.1.1.
This should give you what you're asking for. Of course there are other conceivable fancier setups.
The above setup does not provide Internet access to your OpenWRT router. In case you want to have that you need to apply appropriate routing configuration on that device.

For the moment I would be happy if LAN and WAN interfaces had been assigned a proper MAC read from the box's hardware configuration. With the image you kindly provided all MACs are undefined and therefore default to 00:11:22:33:44:55 though (or are derived by incrementing that MAC).
You mention that the code to read the MACs from the hardware configuration is run only on the first boot, i.e. when /etc/config/network does not exist. Or in other words, once that config file does exist, even in case it does not specify/override MAC addresses, OpenWRT nonetheless no longer attempts to establish the interfaces' MACs from the device's hardware configuration?
That would be weird because any vanilla image which includes an /etc/config/network config file would prevent the particular box's MAC from being read.

... looks like I'll have to dig a bit deeper into the code in order to better understand the mechanism...

If the file /etc/config/network exists then OpenWrt no longer looks for real MAC addresses.
Addressing also depends on these settings:

I had a look how the original firmware handles MACs. There is only one base MAC stored in the config in mtdblock6. There are up to two LAN MAC addresses (base, base+1), then WAN MAC addresses are base+2, and WiFi MAC addresses (in fact four) are base + 6.
With the current OpenWRT image, the base MAC is also read in /etc/board.d/02_network and stored as lan_mac in /etc/board.json, while wan_mac is calculated as base+1 and also stored there.
Wouldn't it make sense to do analogously for the WLAN MAC, just as the original firmware does?

I also had a look at how OpenWRT handles things on a 6431. There the LAN and WLAN MACs (in fact consecutive MACs) apparently do not need to be configured, but are derived from the interface's hardware. The WAN MAC (in fact the subsequent one) is configured in board.json and thus explicitly set in /etc/config/network.
Why do the LAN's and WLAN's MACs on a 6431 not need to explicitly configured in /etc/config/network? What the difference to the Easybox 904 wrt. MAC addresses?

If anyone is interested in an Easybox 904xdsl or two to tinker with, I have two here that I would give away [...]

Edit: Both are gone.

Those from Germany (or elsewhere) interested in an Easybox 904 should search the "give away for free" category on https://www.ebay-kleinanzeigen.de to find one.

1 Like

Is this the most appropriate thread to discuss ISDN (S0 port) support for the Easybox 904 XDSL?
As one can see from dmesg of the original firmware (or e.g. here: http://arny.tjps.eu/OpenWrt/EasyBox904xDSL/oem-firmware-info/bootlog.txt) the ISDN chip is found at 0xb0000000. The original firmware uses an ISDN stack from German vendor Stollmann AG (as a Linux 2.6 kernel module), most likely this product: https://www.yumpu.com/en/document/view/9543226/overview-isdn-software-modules-stollmannde
https://randomprojects.org/wiki/Vodafone_EasyBox_904_xDSL lists the ISDN chip as Lantiq PEF 82902, which is also known as Infineon PEF 82902, found in Stollmann's list of supported chips for their ISDN stack. The original firmware recognizes the chip as IPACX Chip-ID=0x20, which is probably the ID for the Infineon T-SMINTI PEF 82902 within the IPACX family (?) of Infineon ISDN chips.
Infineon chips, at least some of them, are supported by Linux's mISDN: https://cateee.net/lkddb/web-lkddb/MISDN_INFINEON.html
This seems to be limited to PCI cards though.
What would be the interface standard needed here instead? Do you see any chance of getting to work mISDN with the 904's ISDN chip?
(In case another thread is more appropriate please feel free to point out so. thanks)

Sorry for my absense but i have not much time at the moment.
@QAuge
Thanks that you have update to kernel 5.4.x now i have build and it works, but not much testet in the moment.

I think it is good idea when somewere with know how (ähm you) get involved in this diskusion here:

and asking for fixed link definitions.

@gschwarz

AVM use an other Chip (vendor dialog or so POTS and DECT) but this device and the most other Arcadyan devices use the Lantiq SLIC which driver exist. These Lantiq driver need the second core (or better thread).

I am really interrested on ISDN too but fear there is no realistic chance.
There exist two ISDN modules: stollmann_isdn and drv_isdn
possible ICs where have to do with it:
Modular ISDN NT (intelligent): Lantiq PEF 82902 F V1.1 T TSMINTI 4B3T
Voice direct access arrangement (DAA): SiLabs Si3050-FT
TBR-21 line-side device: SiLabs Si3011-FS
But i am not shure if that the PEF 82902 is really for the ISDN S0-bus, i gues it is possible for NTBA splitter etc behind the DSL-connector
see:

PEF 80902 and 82902 see here: http://pdf.datasheetcatalog.com/datasheet/infineon/1-t_sminto_ds1_v11datasheet.pdf

1 Like

hello
i have an easybox 904 xdsl. i successfully installed the fullimage from this website: https://app.box.com/s/tjeobifjb8ohj90m5k2u7g1efgq8308y/folder/60284896266 via TFTP.

after that, i change my network settings to ip 192.168.1.2 and gateway to 192.168.1.1 to be able to access the router interface.

when i got into it, i could upload a sysupdate.bin and flash it. i tried to do it with the sysupdate rom this link: https://app.box.com/s/hvqg535dnubt4r2ontpmtodpvt6ydf00/folder/117668025297

problem is, it never flashes it. im stuck at the fullimage flash from december 2018. it never flashes the 2020 sysupdate, although i upload it successfully, it shows me checksum and "proceed". then this comes up: https://i.imgur.com/f1CPsDx.png for like 2 sec and disappears.

thats all. no reboot, no flash. its doing nothing. unfortunately i didnt find a good tutorial why and how i should fix this. people say in this forum i need to fullimage flash again a newer version, but the only newest fullimage is from december 2018.

i am a bit confused how to solve this. the openwrt tutorial wasnt helpful either, since it never told me about switching ip to 192.168.2.1 and gateway to 192.168.1.1 in the first place. i got the info from this website: https://github.com/majuss/easybox904/blob/master/guides/openwrt.md i would be glad if anyone could help me out. and if possible, try ot explain with simple words and simple instructions.

Not exactly. A new version is available.

hello there and thanks for your answer. i am a bit confused. i thought the repo by Quallenauge is the only thing available for easybox 904. could you explain me how your repo is related to it? like... if i flash yours, can i still get the sys updates by quallenauge? or will the maintainance work differently when i switch to your version?

and how exactly did the others manage to install the version by Quallenauge with the newest sysupdate? like.. do i have to flash all sysupdates in a row starting be the oldest, to be able to get the newest?

Of course, because my images are based on his work.

good to know, thanks! but by any chance, you have an idea why it didnt work with the way Quallenauuge provided? like.. what did i do wrong? seems like all others can successfully install it. is there a different way to do so? or did i just need to sysupgrade form oldest to newest to get the newest version?

i suspect your way of installing the sysupgrade is not correct.

"Administration"> "Login"> "System"> "Backup / Flash Firmware"

enable "Force Upgrade" if necessary

and wait for the box after the update
has booted.

It should be enough to install the latest sysupdate.

well by now i managed to install openwrt on the device, finally lol. but now i have the problem with WAN. i kinda dont understand how to handle 2 vlan switches to assign WAN to a lan port. any combination i do does not work. they either turn each other off in the switches settings, or the changes revert.
so what i try to do is, to use EB904xdsl as a wlan router, not as a dsl modem, since i already use another a dsl modem.
is there any good tutorial how to assign properly a WAN connection to a lan port? or is it even possible to assign WAN to the dsl port or to the isdn port?
im also a bit confused aobut how the ports are named. so i guess LAN1 - LAN 4 are named eth0,1, eth 0,2, eth0,3 and eth 0,66?
and the dsl port is just eth0 while the black isdn port is eth0,77? am i right?

i actually managed to get internet connection without switching modems, but problem is, i managed it by adding an unmanaged to interfaces. i actually want to seperate EB904xdsl with the modem router and i want EB904xdsl to manage the IP, not my modem. so the unmanaged route is not good for me. so yeah, if anyone has any idea how to properly assign a WAN to one of the ports, i would be glad to know.
i run the newest snapshot btw by quallenaugo from 2020-07-10 from this link: https://app.box.com/s/hvqg535dnubt4r2ontpmtodpvt6ydf00/folder/36913951101

EDIT: also tried to add a new WAN to (example) eth0,3. internet works but stillIP is not managed by eb904xdsl. usually it the IP should be displayed in the interfaces under the WAN addition. what i basically want, is to have my modem and eb904xdsl independent as if i would plug in just a wlan router (works with my other openwrt wlan router). jnot sure if this issues accure bc eb904 is actually a dsl modem and not solely a wlan router.

another problem is, somehow i cant update the software packages. i get "Failed to send request: Operation not permitted". how do i actually install some/can connect to the package repos? reason i need this, is, bc there is no wpa set up. no wlan encryption set ups, nothing.

also, somehow i dont get why in switches, in vlan switch0, the LAN is connected to vlan switch01 LAN1. whnever i turn off LAN in switch0, automaticall LAN1 in switch01 is turned off. besides eb904 fails to save the settings. let me show you quickly what i do: https://i.imgur.com/V9YVkYj.png
i basically tried to use lan port 2 as wan.

EDIT 2: so now i connected the lan cable directly to my main dsl router and it turns my eb904 to a switch without any ip. cant access its standard gateway ip anymore. i could do it before when i connected the lan cable to my current openwrt wlan router that connected to my main dsl router. but direct connection between eb904 and my main modem results in my modem overtaking the eb904 and making it non.existence in the network, as if it was just a switch without any interface.

either im a total noob or eb904 is just depressing if you want to use it as a openwrt wlan router connected to the main dsl modem router

Hi @Jum you are totally wrong
ISDN is only for ISDN
There is intern the Lantiq switch0 connected to WLAN WiSoc rt3883 and connected to rtl8367 switch1

Lantiq switch0
port 0 ---Lan1----------------------- rtl8367 switch1
port 4 ---Lan2----------------------- WAN
port 5 ---Lan3-Vlan66-Vlan71--- WLAN WiSoC rt3883
(port means the intern ports not the yellow port outside)

This should work, note guest WLAN eth0.71 are not conneted/enable and not much tested in the past:


config globals 'globals'
	option ula_prefix 'fd36:68fe:1571::/48'

# Port on Easybox 904x switch1 ETH-0 - ETH-3: [DSL+WAN][ISDN][ISDN][ETH-0][ETH-1][ETH-2][ETH-3] (Power)

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch
	option name 'switch1'
	option reset '1'
	option enable_vlan '1'

	
###################################################################
	
	
## hauptswitch switch 1
config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 6t'

## DSL port + wan on eth0.2
config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

## wlan inic
config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option fid '3'
	option ports '5 6t'

## wlan normal
config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '66'
	option fid '4'
	option ports '5t 6t'

## wlan guest
config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '71'
	option fid '5'
	option ports '5t 6t'

##########################################################
	

## hauptswitch switch 1 ports
config switch_vlan
	option device 'switch1'
	option vlan '1'
	option ports '0 1 2 6t'

##########################################################


config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '9c:80:df:91:c9:02'
	
config device 'ethwan_dev'
	option name 'eth0.2'
	option macaddr '9c:80:df:91:c9:01'

config device 'dsl_dev'
	option name 'dsl0'
	option macaddr 'c8:07:84:ed:38:54'

config device 'wlan_dev'
        option name 'eth0.66'
        option macaddr '9c:80:df:91:c9:03'

## guest wlan
# config device 'guest_wlan_dev'
#        option name 'eth0.71'
#        option macaddr '9c:80:df:91:c9:04'

###########################################################


config atm-bridge 'atm'
        option vpi '1'
        option vci '32'
        option encaps 'llc'
        option payload 'bridged'
        option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'b'
	option tone 'av'
	option xfer_mode 'ptm'
	option line_mode 'vdsl'
#	option firmware '/lib/firmware/FB7360.111.06.30/dsp_vr9/vr9-B-dsl.bin'
	

#############################################################


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	
config interface 'inic'
	option proto 'none'
	option ifname 'eth0.3'
	
config interface 'isp0'
	option proto 'none'
	option ifname 'dsl0'
	option ipv6 '0'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.41.1'
	option ip6assign '60'
	option ip6hint 'aa'
	list ip6class 'wan6_dsl'
	list ip6class 'wan6_eth'
	list ifname 'eth0.1'
	list ifname 'eth0.66'

#################################################################


config interface 'wan_dsl'
	option ifname 'dsl0'
	option proto 'pppoe'
	option username 'USER'
	option password 'PASSWORD'
	option ipv6 '1'
	option defaultroute '1'

config interface 'wan6_dsl'
	option ifname '@wan_dsl'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'

config interface 'wan_eth'
	option proto 'dhcp'
	option ifname 'eth0.2'
	option auto '1'

config interface 'wan6_eth'
	option ifname '@wan_eth'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option auto '1'


## DSL port + wan on eth0.2
config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

config device 'ethwan_dev'
	option name 'eth0.2'
	option macaddr '9c:80:df:91:c9:01'

Unfortunately, it doesn't work with kernel 5.4.
Interface eth0.2 is not able to obtain an IP address via DHCP. @Plonk34, can you please help with this matter?

Hmm, Dammed i wich this this device works full once at the beginning.
I check it and i have the same problem.
but the dtsi file diver from the 4.19 wich was working:

1 Like

File dtsi from github @QAuge:

&eth0 {
	lan: interface@0 {
		compatible = "lantiq,xrx200-pdi";
		#address-cells = <1>;
		#size-cells = <0>;
		reg = <0>;
		mac-address = [ 00 11 22 33 44 55 ];
		lantiq,switch;
		/*rtl8367*/
		ethernet@0 {
			compatible = "lantiq,xrx200-pdi-port";
			reg = <0>;
			phy-mode = "rgmii";
			fixed-link {
				speed = <1000>;
				full-duplex;
			};
		};
		/* rt3883 soc */
		ethernet@5 {
			compatible = "lantiq,xrx200-pdi-port";
			reg = <5>;
			phy-mode = "rgmii";
			tx-delay = /bits/ 8 <3>;
			fixed-link {
				speed = <1000>;
				full-duplex;
			};
		};
	};

	wan: interface@1 {
		compatible = "lantiq,xrx200-pdi";
		#address-cells = <1>;
		#size-cells = <0>;
		reg = <1>;
		mac-address = [ 00 11 22 33 44 66 ];
		lantiq,wan;
		/* wan port */
		ethernet@4 {
			compatible = "lantiq,xrx200-pdi-port";
			reg = <4>;
			phy-mode = "gmii";
			phy-handle = <&phy13>;
		};
	};
};

I just replaced that section and eth0.2 functionality is back.

&eth0 {
	interface@0 {
		compatible = "lantiq,xrx200-pdi";
		#address-cells = <1>;
		#size-cells = <0>;
		reg = <0>;
		mac-address = [ 00 11 22 33 44 55 ];
		lantiq,switch;
		
		ethernet@0 { /*rtl8367*/
			compatible = "lantiq,xrx200-pdi-port";
			reg = <0>;
			phy-mode = "rgmii";
			fixed-link {
				speed = <1000>;
				full-duplex;
			};
		};

		ethernet@5 { /* rt3883 soc */
			compatible = "lantiq,xrx200-pdi-port";
			reg = <5>;
			phy-mode = "rgmii";
			tx-delay = /bits/ 8 <3>;
			fixed-link {
				speed = <1000>;
				full-duplex;
			};
		};
		
		ethernet@4 { /* wan port */
			compatible = "lantiq,xrx200-pdi-port";
			reg = <4>;
			phy-mode = "gmii";
			phy-handle = <&phy13>;
		};
	};
};

@Plonk34, thank you very much for your suggestion.

1 Like