Support for Easybox 904 LTE

This particular device has been flashed less than a dozen times. It has been sitting doing nothing and still rebooted into a broken state after a few hours. I'm not quite sure what you mean by "electrical mechanical problems", but it didn't have a lightning strike or a car accident.

For example I have disassembled my router several times, and now the FXS ports a very friable and only one works.

I never opened my device.

That's why I always buy two devices, one can be destroyed during the hacking :smiley:

I don't have Easybox, but the internal uart and its logs could probably help.

Hi @Plonk34,

unfortunately there is still no offical support to this device in Openwrt-wiki. Is it maybe possible that it is because of the wrong topic name? We discuss only Easybox 904 xdsl here an the topic says Easybox 904 LTE...

Could also someone please conclude the actual information and a how-to or something? Maybe @QAuge , @arnysch or @henning-schild could say somehing about what's going on atm or how to proceed into offical support of Openwrt and solve the issue with XRX200 closed source...

I stick with my Box still on an older image and don't know how to proceed to be honest. - It syncs also like often from @majuss described with 18/2 on a 100/40 VVDSL2 subscriber-line.

Thank you very much for all your efforts already at this point!

Hi @suppenkasper0815,
I am not the TO, but I think the name of the thread have historical reasons see post #1, there is a link to a thread with the equal name on the old forum.
"Easybox 904 LTE open source code to be provide soon"
I know it contain Important information for potentially developers for the LTE variant.

what did you exact mean ?
The conclusion of information are in:

It is an General problem of the modems in xrx200 and it is more helpfull to open an separat thread.
But i think you need a vectoring capable Modemfirmware
see this post #3 for explanation.
You must extract an Modemfirmware from an Stockfirmware image like Fritzbox 7490 and copy them to your Routersystem
Them you should add the lines "option firmware "path-to-fw"" in the /etc/config/network under dsl

1 Like

About: ""Add bad block table implementation" BREAKS all other NAND devices that use BBT-pattern"

Of it looks like the best way but this should done by a person that are have contact to the Kernel-developer and do know what are BBT are.
Them i guess it need long time to implement and a result ( so i guess ) are an extra Kernel config parameter.

For this reason it is not better to add a new Kernel parameter like MTD_NAND_CUSTOMIZED_BBT_VGV952CJW33EIR and hatches this service to ./config/

Because there is an other problem: the Easybox-904xDSL need a special openwrt-config like:
Or is this not a Problem ?

But at the moment i can not test i have some strange read errors on mtd device and i have not idea if it a hardware error, a problem with this devicetype or an general linux problem.

While that might make things a bit neater, it won't really help the problem at hand, as the same kernel image is shared among all devices of a (sub-)target. Meaning if you need to enable your hypothetical MTD_NAND_CUSTOMIZED_BBT_VGV952CJW33EIR, and you do, if you want to support the EB904xDSL, you break all other xrx200 devices with NAND at the same time - nothing won. What would be needed here is some way to influence the kind of BBT at runtime, either by adding some kind of quirk for the EB904xDSL or maybe DTS side configuration.

Yes, those are a problem, but compared to BBT and switch support an optional one (display/ touchscreen don't 'need' to work for basic device support --> defer to stage 2).

This is not a problem. DEVMEM is used only to set needed MAC delay settings for port, where Ralink WiFi SoC connected. We can extend device tree parameters for xrx200 ethernet port to set this delay in the register. It just where done as DEVMEM manipulations in original firmware from Arcadian, but, indeed, this is a MAC settings register.

ICYMI: A few hours ago, this commit went into master:

Which includes the ILI9341 in our Easyboxen.

1 Like

I have such a problem with my device.

There a alot of things that fail and can be the reason for the different errors:

So i do not explore for it because it sucks, anything is always wrong since months,
It was not possible to build an stabel fullworking image.
(I build USB-Storage and f2fs inside my kernel)

At the moment i try to build a solution for the special-NAND-bbt-patch-destroy-other-devices problem.
I use minimal images without f2fs and USB-storage support and they are working (but possible that my Flash are defect on a higher position)

If you use the extra Kernel.config from post
do not use this part:

Starting from USB-Stick does not really working too because:
It starts fine from USB-Stick but the overlay-fs is on UBI0_1 (from the size it looks like mtd12).
And this make not really sense.
How can i change it and not using any overlay-fs or using it on /dev/sda1 (f2fs)

About: ""Add bad block table implementation" BREAKS all other NAND devices that use BBT-pattern"

So i have add the field: "customized-samsung-K9F4G08U0x;" under "nand@1 {" inside the VGV952CJW33-E-IR.dts
Inside the drivers/mtd/nand/nand_bbt.c i asked for it and make a decision with or without modified BBT.
Here are the resulting nand_bbt.c and here are the resulting kernel patch: 4052-NAND-add-easybox904-bbt-byDTS.patch.

First test was positiv now i build/test again. If it positiv too, can anybody add this device to openwrt ?

1 Like

I'd try the snapshot. Can you give me a download link please? :slight_smile:

But with the following restriction because it is an testbuild:

  • it was build on raspberry pi for this reason hostarch=arm7l
  • but it is an minimal build without copy all packages from snapshot
  • SMP support (no telefon) only
  • it contain all drivers without USB but they are inside packages and must be install separate (kmod-usb-dwc2)
  • no lcd4linux and i have no idea how can i test the lcd
1 Like

How to switch off backlight of LCD screen?

I would like to thank you for the download link. I really like it so far. Currently I'm trying. :slight_smile:
I need USB. I probe install the (kmod-usb-dwc2), but error Description

This driver provides USB Device Controller support for the Synopsys DesignWare USB OTG Core

  • The installed version of package kernel is not compatible, require 4.14.103-1-71c08020… while 4.14.103-1-5990414d… is installed.

I don't have an EB904 set up right now, but If I remember correctly, the LCD is turned off and on the same way as a system LED. Have a look at QAuge's LUA script.

1 Like


Hey, would you please also tell what's working and what not atm?

  1. Modem?
  2. 5GHz
  3. Mesh-Networks
  4. Voice/ISDN
  5. NF / Software Offloading

Why is it so important to change from JFFS? I haven't gotten the point and also not why the device is still not officially supported?

  1. yes
  2. yes, but the wlan situation as a whole is fragile and might not work at all at the moment.
  3. no
  4. yes/ no
  5. yes, but it won't get you past 60-65 MBit/s either.
1 Like