Support AIoT AC2350 Xiaomi?

Hi. I installed the new snapshot but luci was not working. (SNAPSHOT r17148)

See Support AIoT AC2350 Xiaomi? - #219 by MarioK239


Thanks. Success .

Thank you to everyone, I have been watching the thread, github PR and its awesome to see the build.

I guess it is to be expected, but I am seeing much lower wifi speeds on the snapshot build.

Has anyone tried the 5.10 kernel? maybe there are some improvements in there?

Interesting, I also turned on software offload when I tested mine, can u pls give a test for AC WLAN as well?

I'm really surprised that such a weak CPU can reach gigabit speeds. Is the connection through pppoe? Pppoe adds an extra load on the CPU, that's why I'm asking.

just dhcp... both wan and lan.

and even with all the stats and unnecessary mods.. it does keep 800mbps :slight_smile:
here is the load while testing the 1Gbps lan


good day
greetings to everyone in the community

I'm a newbie, I'm writing from Venezuela. Excuse me, my writing is using a translator, I don't speak English.

but I bought the XIAOMI AC2350 in White color CHINA version currently has version 1.3.8 and I would like to be able to modify the software to take advantage of the modifications since I need to connect to the VPN using OpenVPN I have a subscription with ExpressVPN but using the LT2P configuration it does not work correctly for me streaming services some good samaritan can give me instructions to modify the device without damaging it I suppose there is a risk but I would appreciate the help
I can make a small donation through paypal to help the community and whoever takes the trouble to help me.
Thank you.

as soon as you are on openwrt

if you stick with stock and expressvpn*:

*should work tho ... did not test it personally

i want install openwrt can guys tell me how to do it

Check this

Hello good Morning
I have the same device and I want to install OPENWRT to use openvpn. Can you help me as you successfully set up on your router? I can help with a donation via paypal if it's not too much trouble.
Thank you


thanks for that tutorial although it is mandatory that I open the router? I suppose because there is no final firmware to only install via the web through the router interface, thank you very much.

No. Did you read the guide?

Hi there,
I'm new here and glad to see what a beautiful work have been made.

Hi have white version of AC2350 and followed all steps to install OpenWrt.

I face actually some issues, but I didn't find any help here and somewhere else. Let me know if I have to open a new issue tracking...

My only goal is to use OpenVPN by my CyberGhost premium account, but it doesn't work.

When I upload OVPN configuration file and I click to edit it says : Insufficient permissions to read UCI configuration.
Then all my tries are unsuccessful even if I tried all tutorials founds here.

Then I tried a manual one and add settings required by a easy tutorial with no luck as well.

I found a thread about setting up issue OpenVPN but no custom tutorial was shared to show all the solution.

So question :

  • Do I have to apply some upgrades from System/Software menu ?
  • Anyone knows if Wireguard will have any settings available soon ?

Anyway I have no more clues, I'll appreciate any help or advises.

I've finally fixed OpenVPN connection, just following the official tutorial :

But I found another issue, DNS leak?
I don't get how my pc app makes everything fine and the same .ovpn in the router doesn't.
From my pc app when I test I have a different DNS adresses results compared to the router's one.

I think I'll start from a good sleep...

1 Like

Hi it's been a while since i used openvpn but i may help.
Have you disabled webrtc in the browser you're testing with? And are you testing with your vpn providers dns or something else (outside the vpn tunnel)

Hi mibrick,
I disabled webrtc in the browser and I see no leak now, thanks it worked.

About the second test, I didn't find any DNS servers in my provider account CyberGhostvpn.
I tested several things in DHCPandDNS menu and in the DNS crypt-proxy with no succes.

For better understanding, my pourpose is to have both one IP and one DNS result when I connect the VPN to a specific country, like mobile or desktop application does automatically.
The Openwrt vpn actually give one IP adress related to the country selected, but I have several DNS related to my ISP.

I think I have to redirect DNS or something, I found lots of tutorials and I don't now which one is the right one to apply.

1 Like

Do you have this checked? And ofc put your preferred dns servers below instead or if you use unbound for dns over tls or dnscryptproxy like you mentioned.