Sun8xi (nano pi neo) GPIO "using dummy regulator" messages

When I perform

export 64 > /sys/class/gpio/export

the number could be 65 (PC1), 66 (PC2), 67 (PC3), or 140 (PE12) which are GPIO pins with nothing external connected to the H3 chip, and nothing I have found in the device tree, the openwrt (openwrt-23.05.2-sunxi-cortexa7-friendlyarm_nanopi-neo-ext4-sdcard.img) says

sun8i-h3-pinctrl 1c20800.pinctrl: supply vcc-pc not found, using dummy regulator

for these pins in bank C, and

sun8i-h3-pinctrl 1c20800.pinctrl: supply vcc-pe not found, using dummy regulator

for this pin in bank E.

It all started with me giving names to the GPIO pins in the device tree, after this I started getting vcc-pc error messages in dmesg every 10 seconds.

Initially I thought it is a problem of my build of openwrt. After researching and finding nothing material in the device tree, I tried the pre-built image downloaded some time ago. It showed the same issues. Then I booted nano pi neo core into its original OS flashed into onboard MMC (Ubuntu 20.04 LTS), to see it does NOT say any messages on me trying exporting these pins.

I must say only these GPIO pins give such problems, all others from the list of here function without problems.

Scanned through this and this to understand nothing but that there's a problem with supporting Allwinner GPIO controller(s).

The actual main issue is: I do not care about error messages, if do not bring bigger issues like burning something in the design or interfering with my application using the GPIO pin.

So looking for the advice - what should, and can be done? If message is there in the log, then it must mean something, and lead to something...

Update: looked into the circuit diagram, and tried to operate GPIO 80 (PC16/NAND_DQS/SDC2_RST) and it gives the same message for vcc-pb. Writing to GPIO 141 (PE13) gives same for vcc-pe.

Checking the dmesg output I see the same vcc-pX messages about regulators

vcc-pa vcc-pf vcc-pl vcc-pg

thus I make a guess that when these messages appear in the dmesg exactly some of these banks' pins are being "exported" (or whatever manipulated). Thus what I see in the log when trying to export PC or PE pins may be the same issue as happening with banks PA/PF/PL/PG earlier.

I also have a good idea about why I am getting such message for PC bank every 10 seconds. It seems to be my application trying to open/close the respective lines, which may be similar to export/unexport. Thus ugly workaround could be to export one of PC pins in the system, so that at least one pin would be activated as GPIO and regulator message appears only once... Sounds ugly! And the real problem here is there's nothing to export in bank PC than 4 pins used by my application!

This circuit makes me wondering what happens when I export PC4 and set it to output logical 0... WTF they did not put series resistor in there. By the way, their customer support does not respond.

Your opinion?

Update 2: seems I was correct about those dmesg messages -

PA is having GPIOA10/STATUS-LED, PF having uSD-card, PL is having GPIOL10/PWR-LED, and PG is having GPIOG12/USB0-OTGID (mini-USB detect signal).

Therefore it seems these messages must be about issues with driver or some openwrt compatibility issue.