Subnet mask configuration

I recently flashed OpenWRT to my 1900ACS router. One thing I noticed is that the Subnet mask on the Linksys firmware is and the OpenWRT is My understanding this provides the ability for more hosts. But is there any impact or configuration needed to be made to the other devices on my network. I.E. should I change my wireless device's Subnet mask to

Did you change the subnetmask?

1 Like

See chart here:

Nope...and OpenWrt's default should be, I'm not sure why you see something different.

Your choice, see the cart for amount of needed IPs.

I think what the OP means is, if the subnet mask is set on the router as, does he have to have the subnet mask on other devices the same, or can it use a different subnet mask. Let's say for example that the router has IP of and subnet mask of and client with IP of and subnet mask of Would that work?

Well, with you have already 253 hosts (plus the router).

You are not going to set static IPs for the too many devices you have, are you?

1 Like

It's a broken configuration IMHO.

@ mhegab, I think you understand my question. I don't have many hosts, probably less than 30. I do want about 12 of them to have a static IP. I never changed the subnetmask on either setup (Linksys or OpenWRT). Below is my Linksys network. Linksys
Below is my OpenWRT status:

I was curious how to handle the conflict with the two settings and what if any problems I may see. I see three options for action:

  1. do nothing
  2. change OpenWRT to if I can
  3. change all my devices to

Is this the status of the wan interface?

1 Like

There is no conflict there. Your wan has different netmask than the lan and that is totally fine.

1 Like

The question is, however, why the upstream DHCP server is using such subnet mask? And is it the same router Linksys router shown? Because that one is using

1 Like

Screenshot is from the same router, just toggling between firmware. No tweaking done to either setup.

The openwrt status shows the IPv4 upstream, i.e. the WAN network. But on Linksys it's the LAN network.


Thanks, that is my lack of understanding. So I assume this means all is configured properly. Thanks.

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.