Stuck setting up IPTV

Hi, please can you help get IPTV working. I have followed the instructions here https://openwrt.org/docs/guide-user/network/wan/udp_multicast and have Internet access but not IPTV.

/etc/config/igmpproxy

config igmpproxy
	option quickleave 1
#	option verbose [0-3](none, minimal[default], more, maximum)

config phyint
	option network wan
	option zone wan
	option direction upstream
	list altnet 192.168.1.0/24

config phyint
	option network lan
	option zone lan
	option direction downstream

Also edited /etc/config/network to enable IGMP snooping.

Service is BT FTTC/Youview and router is a Flint 2 running 23.05.4. TV box is wired directly to the router and the cable is good.

What am I missing? It's currently working on an Asus AC88U running merlin with these settings, the Wifi has died though so need to replace it:

LAN - IPTV
Use DHCP routes:
Microsoft
Enable multicasting routing: Enabled
Enable efficient multicasting forwarding (IGMP Snooping): Enabled

May of needed to toggle this to no if it was enabled can't be sure though it's been a long time.
Special Requirements from ISP
Enable VPN + DHCP Connection: No

I have no clue what to try now so any help much appreciate, thanks for reading.

Tried disableing IPV6 and still no go and also tried this which didn't work either Getting IGMPPROXY to work on new router + IGMP Snooping.

Only thing I can think to try now is to flash back factory firmware and see if it's got a more noob friendly way to get it working then maybe see if there are some clues in the config files.

Thank you to everyone who works on this project but I'm going to have to throw in the towel after 3 days of head banging, it's quite sore now :rofl:

Will just buy a router of the ISP. If anyone manages this in the future I'd be intrigued to learn what I've missed and perhaps put the flint 2 to work after all.

Thanks again.

This is usually the SRC of the IPTV traffic from WAN. This subnet is likely incorrect since it's usually the LAN config.

If the altnet is unknown, it's normally configured as 0.0.0.0/0.

Thanks lleachii, just tried setting it to 0.0.0.0/0 but sadly no go still. I think there is extra config needed but I can't figure it out. The answer seems to be in this post Getting IGMPPROXY to work on new router + IGMP Snooping - #4 by philtrick and I've tried adding some stuff from philtrick config files but all I've acheived is locking myself out the router and breaking the internet. So now need to lookup recovery options and setup from scratch.

I also found this https://github.com/danieljackcox/openbsd-bt-youview which I feel should help but I'm going cross eyed trying to figure this out :smiling_face_with_tear:

Wooho, it's working! Managed to figure it out with lleachii advise above and the info in post 6 and 7 here https://forum.archive.openwrt.org/viewtopic.php?id=52406#p246080

I'll post what I did and hopefully it helps others.

Install igmpproxy then use WinSCP or similar to edit the config files as follows. Note physical wan port name (in this case eth1) might differ so change accordingly, other sections in the config files will give you a clue what it should be.

In igmpproxy

Replace

config phyint
	option network wan
	option zone wan
	option direction upstream
	list altnet 192.168.1.0/24

With

config phyint
	option network iptv
	option zone wan
	option direction upstream
	list altnet 109.159.247.0/24

In network

Add

	option igmp_snooping '1'

To the end of this section so it looks like this

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.3'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option igmp_snooping '1'

Add this to the end of the file

config interface 'iptv'
	option device 'eth1'
	option proto 'static'
	option ipaddr '10.22.22.1'
	option netmask '255.255.255.0'

In firewall

Add

	list   network		'iptv'

Into this section

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	list   network		'iptv'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

Add this to the end of the file

config rule
	option src		'wan'
	option proto		'igmp'
	option target		'ACCEPT'
	option name		'IGMP (IPTV)'
	option enabled		'1'

config rule
	option src		'wan'
	option proto		'udp'
	option dest		'lan'
	option dest_ip		'224.0.0.0/4'
	option target		'ACCEPT'
	option family		'ipv4'
	option name		'Multicast'
	option enabled		'1'

That should be it, a router reboot may be required.

I hope it saves some hair pulling. Good luck and thanks again for this firmare and the help.

1 Like

Interesting - I must have missed your IPTV was on a different network (in fact, I don't see any WAN config). I see you noted your ISP. Must be information you didn't mention/include at the time. Congrats on figuring it out!

The IPTV is provided by the ISP, BT. They allow you to use a third party router but don't provide the IPTV config. So all the info I had to provide was the ISP.

I don't fully understand how it works, I think the IPTV traffic is sent alongside the internet traffic (I don't know if that's the right term) so you have to give it a fake address to capture it and pipe it through. Not sure if I've got that right but this line from the archived topic I linked above probably explains is better than I could.

Because the IPTV traffic isn't sent across your ISP's PPPoE connection (it's injected from the fibre cabinet) you need to add an IP address to your WAN port underneath the PPP connection.

I hope that makes it make more sense. Thanks again.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.