Struggling with serial connection on Zyxel GS1900-48

Hi, bricked my Zyxel GS1900-48 with the wrong openwrt image. Now I connected to the serial console, after soldered cables by following the commit message (;a=commit;h=47f5a0a3eed593e147ee1bdd36ea532ee266ba18)

To connect to the UART, wires can be soldered to R603 (TX) and R602 (RX).

So after I connected to Mini USB to TTL adapter (FT232RL FTDI) I am receiving the serial console output, but what I am struggling with is to send keyboard inputs. For example pressing the "SPACEBAR" while showing:

Press SPACE to abort boot script

does not abort the boot sequence, it just continues.

What am I missing?

Thanks in advance to anyone who can point me in the right direction :slight_smile:

Why did you solder to R602 and R603 while you could have used J4 with a "regular" RS232 adapter?

I would double-check the pinout, maybe you soldered to the wrong side of the resistor?

1 Like

Hi andyboeh, thanks for your reply! That's a good question, at first I tried to connect to the RS232 connector (J4) via a PL-2303 - RS232 Serial to USB adapter. Trying various baudrates and settings I always received garbled output. And as I know to little about serial connections, I tried the other solution connecting via soldered wires.

That's also a good hint, do I have to solder the wire after or before the resistor? I soldered it after the resistor.

“After or before a rectangle…”

These are usually pull-up resistors on communication lines so you need to solder it to the signal side.

You have the ground wire somewhere also I hope?

1 Like

Thank you.

Yes, I used the ground from the r232 header.
Now the tiny pull-up resistor is loose. Any idea what happens if I can't solder it back on the board? :worried:

Pretty simple actually. No resistor=no serial in any way or form.

The thing with surface mount technology is that the pcb and components pretty much only survives one solder cycle of about 2seconds. And with lead free solder tin you must have at least 450°C on the solder iron tip with low thermal resistance on the tip to even melt the solder tin to begin with fast enough and that results in even lower life expectancy for the PCB.

1 Like

But I have trouble see why the rs232 connector wasn’t able to get working?

Some are just incompatible. The first one I tried on my GS1910 also wouldn't work, then I remembered I had a 15+ years old one lying around and that connected just fine.

Sorry for my late reply.
Thanks for the tip with solder iron, I was able to solder another resistor on the board. At the moment I am a bit afraid to solder another cable onto it. Any idea how much Ohm such a rectangle SMD resistor might have. I was not able to measure it with my multimeter.

As for the rs232 I found some information that there are different pinouts (, but with a different cable I am still gettting no data. With the DTK I at least getting garbled output.

How do I figure out the right pinout?

What do you mean with:

Some are just incompatible. The first one I tried on my GS1910 also wouldn't work, then I remembered I had a 15+ years old one lying around and that connected just fine.

The DB9 to Board cable?

Just for the record, I truly appreciate your answers and help. I do not take this for granted. :slightly_smiling_face:

Every size of smt resistors except for the smallest ones have the value painted between the connectors in three numbers, first digit, second digit and number of zeroes.

But is it a resistor if you can’t measure the resistance, it could be a capacitor also and they have no numbers if it isn’t a tantal cap!?

For serial data I would guess somewhere around 400-10kohm. It is more a matter of pcb trace capacitance multilied with resistance multiplied with 5 to get the rise time inside max rise time specified for the communication standard used.
At least if you care about the engineering science.

Most people including hobby engineers don’t care about science so a resistor in the size if a couple of kohm is usually found as pull-ups.

For the pinout the easiest way is to trace the connector pins to the rs232 chip with the multimeter (continuity/resistance). The DB9 connector on the cable must in all old fashion common sense be the old standard rs232 pin out.

Or it could be a jumper, looking exactly like a resistor but with only a "0" printed on it. It's hard to see, but to me it looks like both R602 and R603 are jumpers:

Put there to make the connection to the RS232 circuitry optional?

(FWIW, I would have used the RS232 port. It can't be that hard to make it work? At least I would have tried to debug it with a multimeter before attempting any SMD soldering...)

But that is still a resistor with 0ohm.

Sure. But it's often hard to measure 0 ohm unless you expect it, since it's difficult to put any sort of voltage over it without a really powerful current source :wink:

Does your board have the level converter chip U8 installed?

It looks like if it doesn't have U8, 3.3 volt levels can be jumpered to J4 through R591 and R606. If it does have U8 there should already be true RS232 levels on J4.

You guys and girls really need better (more expensive) instruments.

The manufacturer usually will specify a (very small) maximum allowable resistance which is due to their design and materials, but they aren't made to have any specific resistance.

Actually that could make sense, I tested those jumpers/resistors and their all have a passage of current (if that's the right phrase).
They are so tiny, but looks like a rectangle or could be also a zero.

@mk24: The U8 is a Sipex ST3232EC and R602 is connected to T1in and R603 to R1out. Yes on J4 there should be a R232. But I am getting garbled output when connecting via a RS232 Serial to USB adapter (PL-2303) on various baudrates and using 8N1. Maybe I am using the wrong equipment (Cable/Adapter)

You need an actual RS-232 port with a 9 pin D plug or a Cisco type RJ45, and appropriate connection adapters. The USB adapters that have individual square pins or loose wires are 3.3 volt level and will not work.

1 Like