Struggling reverting to stock firmware on WAX202

Hey, I have a Netgear WAX202 (serving as an access point connected to another router). I've spend the last two days and about a total of 7 hours trying to get it back it its stock firmware. I have the firmware downloaded, I have WinSCP, TFTPD64, and nmrpflash, and none of them have helped. I have also completely disabled my firewall and antivirus out of desperation, so those probably haven't been the issue.

I have tried:

  1. Uploading the firmware via the WebUI.
  2. Using nmrpflash (it doesn't detect any network interfaces).
  3. Uploading the firmware via WinSCP, SSHing into the device, and doing sysupgrade -F.
  4. TFTPD64, as the Netgear article said to do, and also TFTP via the Windows command prompt.

Please, I'm begging anyone to help. I'm willing to try almost anything at this point. But if you comment, it would be really nice if you explained stuff in detail, I want to keep the chance of errors/mistakes to a minimum.

Did you follow the instructions in the Wiki?


(There's a link to the OEM's instructions there too.)

that's not an openwrt issue though

those are two differnt things.

not sure about the 202, but the 206 got two FWs, did you try good old reset ?

1 Like

Yep, I’ve tried TFTP

that's not an openwrt issue though

those are two differnt things.

Yeah I was just mentioning the things I've tried.

not sure about the 202, but the 206 got two FWs, did you try good old reset ?

Could you elaborate on that? What's an FW?

FW = firmware.

The 206 always have a backup firmware to go to, if you use the reset, but I'm not sure the same applies to the 202.

Let me try to solicit more detail from you in attempt to help you. Since your answer lacked detail, I tested myself. It didn't work.

Wait for the Power LED to light orange and start flashing.

Does this ever occur on your device?

I ask because it doesn't occur on mine, but you never mention it.

@Ansuel -;a=commit;h=0f068e7c4a83bcbf20c4e52a5f8a3f1fe2af2246

Revert to stock firmware:
* Flash the stock firmware to the bootloader using TFTP/NMRP.

I don't think that's the case for the 202, but do you know how I might check? I tried holding down the reset button and all it did was reboot the router.

Well not in an obvious way, no. It cycles through various colors and patterns, but when I tried it I don't remember it clearly flashing orange.

Did you ever figure this out? I've been trying to revert a WAX202 to stock firmware without any success. I started with nmrplash, but it kept timing out after 60 seconds.

I then tried TFTPD64, but when I press PUT (after the power LED has started to flash orange), nothing happens and the router just returns to openWRT.

In both cases, I was connected directly to the router with an ethernet cable and had Windows Firewall turned off.

Nope. I’ve just been plugging my cable directly into my PC rather than the router because I’m too lazy to deal with it now. I intent to keep using it for now, it may actually be useful for wireless VR (which is what I originally bought the router for) to stay OpenWRT.

Sorry about your struggles. Have you looked at serial or JTAG restoration?


I walked away from this, but came back to it today. Still couldn't get nmrpflash or TFTP64 to work. I also tried the built-in Windows TFTP command line, but was never able to connect to the router. All of the posts say to be patient and keep trying, but I must have done it 30 times.

The solution came from this post and this post. I had to manually upload the firmware with scp, then SSH in to write it.

Here's the full procedure for anyone else who runs into the same issues.

  1. Reset OpenWRT so that there's no password on the root user.
  2. Follow steps 1 through 5.d in Netgear's How do I upload firmware to my NETGEAR router using TFTP from the Microsoft Windows Command Prompt? webpage.
    • I also recommend renaming the firmware to be wax202.img
  3. Instead of using tftp to put the file on the router, use the scp command to upload to the tmp folder.
    • scp wax202.img root@

Windows might display a warning that looks like this:

The authenticity of host ' (' can't be established.
ED****5 key fingerprint is ***********************.
This key is not known by any other names
Are you sure you want to continue connecting (yes/no/[fingerprint])?

If so, type yes and Enter to continue.

Warning: Permanently added '' (ED****5) to the list of known hosts.
WAX202.img                                       100%   22MB   5.4MB/s   00:04
  1. Close the command prompt window.
  2. SSH into the router using a client such as PuTTY
    • Host name:
    • Port: 22
  3. Change to the tmp directory and write the firmware.
    • cd /tmp
    • mtd write wax202.img firmware # mtd3 is 'firmware'
  4. Unplug and plug the router to reboot.

It will take a few minutes to install the stock firmware. I expected the router to revert to factory settings, but it retained the last settings I had before flashing OpenWRT onto it.

Good grief.

Can you add this to the Wiki - if you feel comfortable?

It would greatly help others.

1 Like

Thanks, but I'll decline. I wanted to try out OpenWRT, but the WAX202's performance is so mediocre that I'm returning it (hence needing to revert to the OEM firmware). As a result, I'm not using OpenWRT and don't have much reason to stick around here, though that might change in the future. I'd just be requesting access to the wiki in order to add these instructions and walk away.

You're more than welcome to use what I've posted, and I'm happy to offer any clarifications if something doesn't make sense.

Odd, I get superior performance compared to stock.

I didn't understand [until now] that you were reverting because of bad experience with the device's performance running OpenWrt.

Best wishes.

Oops, that should have been "I'm returning it", not "I'm returning to it". Meaning, I'm sending the WAX202 back to Amazon.

I found that the line-of-sight performance with my Windows PC, Galaxy Note 10, and Meta Quest 2 (all AX devices) was solid with OpenWRT. However, as soon as I go into another room, my phone's network speed gets cut in my half (even though it's less than 20ft from the router). I didn't do much comparison with the OEM firmware since I've had so much difficulty reverting, but it's no better than what I'm getting from my existing Netgear Orbi. So, I think for now it's best to send the WAX202 back before the return period expires.

The other thing I've realized is that "playing" with OpenWRT really requires multiple devices, so that I can mess around with one without taking down my whole network. Now that I've gotten my feet wet, I think I'll have a better understanding of how to set myself up if/when I try OpenWRT again.


Oh wow. Yea. I did recall.