Stripped firmware TL-WR940N(BR) v6

I need to rollback to my router's stock firmware but... I can't find any stripped firmware, and I don't know how to strip it in a safe way, I can't find any site or forum (even here) with the stripped firmware, so if someone have it or know how to strip this router's firmware, please help me. (I'm new to all of this router and firmware thing)

the closest i could find was the stripped for the v3:

but the problem is that the flash brands are different, and this may cause trouble. i will let someone more familiar with this methodology (flashing stripped stock FW) to advise you whether it is a good idea.

1 Like

Yeah, I also found that firmware on the web archive sometime ago, but sadly, it'll brick my device if I try that one... Well, I'll be waiting for some firmware or tutorial, or in the last case, learn about tftp because apparently it's a thing that can restore to the stock.
And thank you for your answer.

there's lots of tutorials, if you haven't tried those.

apparently the tftp can be a little spotty, but one guy on the dd-wrt forums experienced error 18005:

Error code: 18005
Upgrade unsuccessfully because the version of the upgraded file was incorrect. Please check the file name.

he said, to get back to stock, you need to do this:

I used the oldest firmware they had posted, and also the newest. Couldn't get it to accept the files through the GUI.

Finally figured out how to do TFTP (you have to set up a SERVER on your machine, which you place at the address; name the file to be uploaded wr940nv6_tp_recovery.bin; and hold down the reset button as you boot the router). Tried letting the router (which gave itself the IP address suck in each of the DD-WRT .bin files you posted. All I got was repeated reboots. Fortunately, I found that I could debrick by renaming the stock firmware to the same filename and letting the router suck that file in.

Last edited by Brett Glass on Tue Mar 20, 2018 1:35; edited 3 times in total

1 Like

WHOA! I DID IT! Thank you for the help, and I'll let a video that I watched which helped me a lot too:
TP Link Router Recovery From Bricked TFTP Method WR940N No Serial Connection Required Works on Most - YouTube

1 Like

good job. yeah i heard it can be tricky.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.