Strange issue, firewall rules?

Hello, i'm facing a strange issue on v19.7.7
Some months ago I remember I've setup a firewall rule to block Supercell games. I dont remember exactly where/how, btw some time later I've removed it. Everything was working fine.
Yesterday I've added 3 firewall rules, to limit some mac addresses and they are working fine BUT somehow now also Supercell games are blocked again. I cant see the supercell blocking rule anywhere on my current setup, I've looked at this files: /etc/config/network ; /etc/config/wireless ; /etc/config/dhcp ; /etc/config/firewall . I dont really know where else to look at the "blocking rule" nor why it popped out again.
Thanks in advance for any help

Check /etc/firewall.user

2 Likes

Hi and thanks for the answer, btw I checked /etc/firewall.user and it's empty. Any other suggestion?
Thanks

You could check /etc/rc.local which is the last startup script.

1 Like

Perhaps you are loading a different user file from "/etc/config/firewall"?

1 Like

Hi and thanks for the answer, btw I checked /etc/rc.local and it's empty. (contains just "exit 0" line) Any other suggestion?
Thanks

Hello and thanks for the answer. It seems not if I understand well, I should have only default user.
The firewall config is like that:

config defaults                                 
        option syn_flood '1'                     
        option input 'ACCEPT'                    
        option output 'ACCEPT'                   
        option forward 'REJECT'                  
                                                 
config zone                                      
        option name 'lan'                        
        list network 'lan'                       
        option input 'ACCEPT'                    
        option output 'ACCEPT'                   
        option forward 'ACCEPT'                  
                                                 
config zone                                      
        option name 'wan'                        
        list network 'wan'                       
        list network 'wan6'                      
        option input 'REJECT'                    
        option output 'ACCEPT'                   
        option forward 'REJECT'                  
        option masq '1'                          
        option mtu_fix '1'                       
                                                 
config forwarding                               
        option src 'lan'                         
        option dest 'wan'                        
                                                 
config rule                                      
        option name 'Allow-DHCP-Renew'           
        option src 'wan'                         
        option proto 'udp'                       
        option dest_port '68'                    
        option target 'ACCEPT'                   
        option family 'ipv4'                     
                                                 
config rule                                      
        option name 'Allow-Ping'                 
        option src 'wan'                         
        option proto 'icmp'                      
        option icmp_type 'echo-request'          
        option family 'ipv4'                     
        option target 'ACCEPT'                   

config rule                            
        option name 'Allow-IGMP'       
        option src 'wan'               
        option proto 'igmp'            
        option family 'ipv4'           
        option target 'ACCEPT'         
                                       
config rule                            
        option name 'Allow-MLD'        
        option src 'wan'               
        option proto 'icmp'            
        option src_ip 'fe80::/10'      
        list icmp_type '130/0'         
        list icmp_type '131/0'         
        list icmp_type '132/0'         
        list icmp_type '143/0'         
        option family 'ipv6'           
        option target 'ACCEPT'         
                                       
config rule                            
        option name 'Allow-ICMPv6-Input'
        option src 'wan'                
        option proto 'icmp'             
        list icmp_type 'echo-request'   
        list icmp_type 'echo-reply'     
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'         
        list icmp_type 'time-exceeded'          
        list icmp_type 'bad-header'             
        list icmp_type 'unknown-header-type'    
        list icmp_type 'router-solicitation'    
        list icmp_type 'neighbour-solicitation' 
        list icmp_type 'router-advertisement'   
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'                 
        option family 'ipv6'                    
        option target 'ACCEPT'  
        
config rule                                     
        option name 'Allow-ICMPv6-Forward'      
        option src 'wan'                        
        option dest '*'                         
        option proto 'icmp'                     
        list icmp_type 'echo-request'           
        list icmp_type 'echo-reply'             
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'         
        list icmp_type 'time-exceeded'          
        list icmp_type 'bad-header'             
        list icmp_type 'unknown-header-type'    
        option limit '1000/sec'                 
        option family 'ipv6'                    
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-IPSec-ESP'           
        option src 'wan'                        
        option dest 'lan'                       
        option proto 'esp'                      
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-ISAKMP'              
        option src 'wan'                        
        option dest 'lan'                       
        option dest_port '500'                  
        option proto 'udp'                      
        option target 'ACCEPT'                  
                                                
config include                                  
        option path '/etc/firewall.user'        
                                                
config rule                                     
        option src 'lan'                        
        option dest 'wan'                       
        option start_time '21:35:00'            
        option stop_time '09:00:00'             
        option target 'REJECT'                  
        option name 'KIDS_En1'           
        list src_mac 'z'        
        option weekdays 'Sun Mon Tue Wed Thu Fri'
                                                 
config rule                                      
        option stop_time '09:00:00'              
        option weekdays 'Sun Mon Tue Wed Thu Fri'
        option src 'lan'                         
        option name 'KIDS_Mar1'              
        option target 'REJECT'                   
        option start_time '21:30:00'             
        option dest 'wan'                        
        list src_mac 'zzzz'         
                                                 
config rule                                      
        option weekdays 'Sun Mon Tue Wed Thu Fri'
        option src 'lan'                         
        option name 'KIDS_Mar2'             
        option stop_time '09:00:00'              
        option dest 'wan'                        
        option start_time '21:30:00'             
        option target 'REJECT'                   
        list src_mac 'zzzz'               
                                                 

Dump the firewall rules:
iptables-save -c -t filter
Let us know which rule allegedly blocks supercell games.

1 Like

Hello and thanks for the answer. As I said, the rule blocking supercell was removed months ago. Now I cant remember exactly where it was, if it was a firewall rule or whatelse. I remember it was directed to one or two specific ips.
Please find the data requested:

# Generated by iptables-save v1.8.3 on Thu Jul 29 15:38:42 2021
*filter
:INPUT ACCEPT [1:75]
:FORWARD DROP [0:0]
:OUTPUT ACCEPT [0:0]
:forwarding_lan_rule - [0:0]
:forwarding_rule - [0:0]
:forwarding_wan_rule - [0:0]
:input_lan_rule - [0:0]
:input_rule - [0:0]
:input_wan_rule - [0:0]
:output_lan_rule - [0:0]
:output_rule - [0:0]
:output_wan_rule - [0:0]
:reject - [0:0]
:syn_flood - [0:0]
:zone_lan_dest_ACCEPT - [0:0]
:zone_lan_forward - [0:0]
:zone_lan_input - [0:0]
:zone_lan_output - [0:0]
:zone_lan_src_ACCEPT - [0:0]
:zone_wan_dest_ACCEPT - [0:0]
:zone_wan_dest_REJECT - [0:0]
:zone_wan_forward - [0:0]
:zone_wan_input - [0:0]
:zone_wan_output - [0:0]
:zone_wan_src_REJECT - [0:0]
[1152:97653] -A INPUT -i lo -m comment --comment "!fw3" -j ACCEPT
[10913:1239169] -A INPUT -m comment --comment "!fw3: Custom input rule chain" -j input_rule
[7158:840394] -A INPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[32:1920] -A INPUT -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m comment --comment "!fw3" -j syn_flood
[3341:372028] -A INPUT -i br-lan -m comment --comment "!fw3" -j zone_lan_input
[414:26747] -A INPUT -i eth1 -m comment --comment "!fw3" -j zone_wan_input
[817953:817836606] -A FORWARD -m comment --comment "!fw3: Custom forwarding rule chain" -j forwarding_rule
[799263:816249950] -A FORWARD -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[18687:1586435] -A FORWARD -i br-lan -m comment --comment "!fw3" -j zone_lan_forward
[0:0] -A FORWARD -i eth1 -m comment --comment "!fw3" -j zone_wan_forward
[3:221] -A FORWARD -m comment --comment "!fw3" -j reject
[1152:97653] -A OUTPUT -o lo -m comment --comment "!fw3" -j ACCEPT
[8339:1758628] -A OUTPUT -m comment --comment "!fw3: Custom output rule chain" -j output_rule
[6054:1600403] -A OUTPUT -m conntrack --ctstate RELATED,ESTABLISHED -m comment --comment "!fw3" -j ACCEPT
[15:4480] -A OUTPUT -o br-lan -m comment --comment "!fw3" -j zone_lan_output
[2270:153745] -A OUTPUT -o eth1 -m comment --comment "!fw3" -j zone_wan_output
[299:22594] -A reject -p tcp -m comment --comment "!fw3" -j REJECT --reject-with tcp-reset
[3:694] -A reject -m comment --comment "!fw3" -j REJECT --reject-with icmp-port-unreachable
[32:1920] -A syn_flood -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -m limit --limit 25/sec --limit-burst 50 -m comment --comment "!fw3" -j RETURN
[0:0] -A syn_flood -m comment --comment "!fw3" -j DROP
[16:4808] -A zone_lan_dest_ACCEPT -o br-lan -m comment --comment "!fw3" -j ACCEPT
[18687:1586435] -A zone_lan_forward -m comment --comment "!fw3: Custom lan forwarding rule chain" -j forwarding_lan_rule
[0:0] -A zone_lan_forward -p tcp -m mac --mac-source -removed- -m time --timestart 21:35:00 --timestop 09:00:00 --weekdays Mon,Tue,Wed,Thu,Fri,Sun --kerneltz -m comment --comment "!fw3: KIDS_EnricoCell" -j zone_wan_dest_REJECT
[0:0] -A zone_lan_forward -p udp -m mac --mac-source -removed- -m time --timestart 21:35:00 --timestop 09:00:00 --weekdays Mon,Tue,Wed,Thu,Fri,Sun --kerneltz -m comment --comment "!fw3: KIDS_EnricoCell" -j zone_wan_dest_REJECT
[0:0] -A zone_lan_forward -p tcp -m mac --mac-source -removed- -m time --timestart 21:30:00 --timestop 09:00:00 --weekdays Mon,Tue,Wed,Thu,Fri,Sun --kerneltz -m comment --comment "!fw3: KIDS_MartaTab" -j zone_wan_dest_REJECT
[0:0] -A zone_lan_forward -p udp -m mac --mac-source -removed- -m time --timestart 21:30:00 --timestop 09:00:00 --weekdays Mon,Tue,Wed,Thu,Fri,Sun --kerneltz -m comment --comment "!fw3: KIDS_MartaTab" -j zone_wan_dest_REJECT
[0:0] -A zone_lan_forward -p tcp -m mac --mac-source -removed- -m time --timestart 21:30:00 --timestop 09:00:00 --weekdays Mon,Tue,Wed,Thu,Fri,Sun --kerneltz -m comment --comment "!fw3: KIDS_MartaCell" -j zone_wan_dest_REJECT
[0:0] -A zone_lan_forward -p udp -m mac --mac-source -removed- -m time --timestart 21:30:00 --timestop 09:00:00 --weekdays Mon,Tue,Wed,Thu,Fri,Sun --kerneltz -m comment --comment "!fw3: KIDS_MartaCell" -j zone_wan_dest_REJECT
[18687:1586435] -A zone_lan_forward -m comment --comment "!fw3: Zone lan to wan forwarding policy" -j zone_wan_dest_ACCEPT
[0:0] -A zone_lan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
[1:328] -A zone_lan_forward -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[3341:372028] -A zone_lan_input -m comment --comment "!fw3: Custom lan input rule chain" -j input_lan_rule
[0:0] -A zone_lan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
[3341:372028] -A zone_lan_input -m comment --comment "!fw3" -j zone_lan_src_ACCEPT
[15:4480] -A zone_lan_output -m comment --comment "!fw3: Custom lan output rule chain" -j output_lan_rule
[15:4480] -A zone_lan_output -m comment --comment "!fw3" -j zone_lan_dest_ACCEPT
[3340:371953] -A zone_lan_src_ACCEPT -i br-lan -m conntrack --ctstate NEW,UNTRACKED -m comment --comment "!fw3" -j ACCEPT
[1033:50466] -A zone_wan_dest_ACCEPT -o eth1 -m conntrack --ctstate INVALID -m comment --comment "!fw3: Prevent NAT leakage" -j DROP
[19923:1689386] -A zone_wan_dest_ACCEPT -o eth1 -m comment --comment "!fw3" -j ACCEPT
[0:0] -A zone_wan_dest_REJECT -o eth1 -m comment --comment "!fw3" -j reject
[0:0] -A zone_wan_forward -m comment --comment "!fw3: Custom wan forwarding rule chain" -j forwarding_wan_rule
[0:0] -A zone_wan_forward -p esp -m comment --comment "!fw3: Allow-IPSec-ESP" -j zone_lan_dest_ACCEPT
[0:0] -A zone_wan_forward -p udp -m udp --dport 500 -m comment --comment "!fw3: Allow-ISAKMP" -j zone_lan_dest_ACCEPT
[0:0] -A zone_wan_forward -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port forwards" -j ACCEPT
[0:0] -A zone_wan_forward -m comment --comment "!fw3" -j zone_wan_dest_REJECT
[414:26747] -A zone_wan_input -m comment --comment "!fw3: Custom wan input rule chain" -j input_wan_rule
[0:0] -A zone_wan_input -p udp -m udp --dport 68 -m comment --comment "!fw3: Allow-DHCP-Renew" -j ACCEPT
[0:0] -A zone_wan_input -p icmp -m icmp --icmp-type 8 -m comment --comment "!fw3: Allow-Ping" -j ACCEPT
[115:3680] -A zone_wan_input -p igmp -m comment --comment "!fw3: Allow-IGMP" -j ACCEPT
[0:0] -A zone_wan_input -m conntrack --ctstate DNAT -m comment --comment "!fw3: Accept port redirections" -j ACCEPT
[299:23067] -A zone_wan_input -m comment --comment "!fw3" -j zone_wan_src_REJECT
[2270:153745] -A zone_wan_output -m comment --comment "!fw3: Custom wan output rule chain" -j output_wan_rule
[2270:153745] -A zone_wan_output -m comment --comment "!fw3" -j zone_wan_dest_ACCEPT
[299:23067] -A zone_wan_src_REJECT -i eth1 -m comment --comment "!fw3" -j reject
COMMIT
# Completed on Thu Jul 29 15:38:42 2021

1 Like

There isn't any rule in there to block anything outside of the kids.

How can be than, that Supercell games are blocked again? Maybe its not in the firewall? Or in some cache? The kids are complaining strong :slight_smile:
Thanks

It could be block on DNS level.
If you don't know what can be the problem, then take a backup, reset the OpenWrt, and start configuring step by step from the backup.

1 Like

I made a backup and watched every single file contained but nothing shows Supercell ip so it is stored in some file that is not backupped.

A couple months ago you posted a configuration showing OpenDNS. Be sure OpenDNS is not blocking it.

2 Likes

Hello, thanks for the reply. Not sure how to check that is not opendns, btw /etc/config/dhcp has nothing blocking any site.

Ok I did it. I did

firstboot -y && reboot now

Then upgraded to 21rc04 and then configured back by hand.
Still unable to reach supercell games.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/* ; head -n -0 /etc/resolv.* /tmp/resolv.* /tmp/resolv.*/*
1 Like

Hello and thanks for your support. RC4 is giving me some errors " RPCError - RPC call to uci/get failed with ubus code 9: Unspecified error" errors I hadnt with v19. Btw I also noticed that for my device GL iNet B1300 there is no "factory reset" image, only upgade... why this?
Thanks again and here is the output:

{
	"kernel": "5.4.137",
	"hostname": "OpenWrt",
	"system": "ARMv7 Processor rev 5 (v7l)",
	"model": "GL.iNet GL-B1300",
	"board_name": "glinet,gl-b1300",
	"release": {
		"distribution": "OpenWrt",
		"version": "21.02.0-rc4",
		"revision": "r16256-2d5ee43dc6",
		"target": "ipq40xx/generic",
		"description": "OpenWrt 21.02.0-rc4 r16256-2d5ee43dc6"
	}
}
package network

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fd08:502e:7c04::/48'

config interface 'lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option device 'br-lan'
	option gateway '192.168.1.1'
	list dns '208.67.222.123'
	list dns '208.67.220.123'

config interface 'wan'
	option device 'eth1'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'

config interface 'wan6'
	option proto 'dhcpv6'
	option device 'eth1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '3 4 0'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0'

uci: Parse error (EOF with unterminated ') at line 45, byte 480
package firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config rule
	option name 'KIDS_timefilter'
	option src 'lan'
	list src_mac 'zzz'
	list src_mac 'xxx'
	list src_mac 'yyy'
	option dest 'wan'
	option target 'REJECT'
	option start_time '21:35:00'
	option stop_time '09:00:00'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    inet 192.168.1.2/24 brd 192.168.1.255 scope global eth1
       valid_lft forever preferred_lft forever
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.2.1/24 brd 192.168.2.255 scope global br-lan
       valid_lft forever preferred_lft forever
default via 192.168.1.1 dev eth1 
192.168.1.0/24 dev eth1 scope link  src 192.168.1.2 
192.168.2.0/24 dev br-lan scope link  src 192.168.2.1 
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1 
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1 
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1 
broadcast 192.168.1.0 dev eth1 table local scope link  src 192.168.1.2 
local 192.168.1.2 dev eth1 table local scope host  src 192.168.1.2 
broadcast 192.168.1.255 dev eth1 table local scope link  src 192.168.1.2 
broadcast 192.168.2.0 dev br-lan table local scope link  src 192.168.2.1 
local 192.168.2.1 dev br-lan table local scope host  src 192.168.2.1 
broadcast 192.168.2.255 dev br-lan table local scope link  src 192.168.2.1 
0:	from all lookup local 
32766:	from all lookup main 
32767:	from all lookup default 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::9683:c4ff:fe04:ddfc/64 scope link 
       valid_lft forever preferred_lft forever
9: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd08:502e:7c04::1/60 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::9683:c4ff:fe04:ddfb/64 scope link 
       valid_lft forever preferred_lft forever
10: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::9683:c4ff:fe04:ddfb/64 scope link 
       valid_lft forever preferred_lft forever
11: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fe80::9683:c4ff:fe04:ddfc/64 scope link 
       valid_lft forever preferred_lft forever
fd08:502e:7c04::/64 dev br-lan  metric 1024 
unreachable fd08:502e:7c04::/48 dev lo  metric 2147483647 
fe80::/64 dev br-lan  metric 256 
fe80::/64 dev wlan0  metric 256 
fe80::/64 dev eth1  metric 256 
fe80::/64 dev wlan1  metric 256 
local ::1 dev lo table local  metric 0 
anycast fd08:502e:7c04:: dev br-lan table local  metric 0 
local fd08:502e:7c04::1 dev br-lan table local  metric 0 
anycast fe80:: dev wlan0 table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
anycast fe80:: dev eth1 table local  metric 0 
anycast fe80:: dev wlan1 table local  metric 0 
local fe80::9683:c4ff:fe04:ddfb dev wlan0 table local  metric 0 
local fe80::9683:c4ff:fe04:ddfb dev br-lan table local  metric 0 
local fe80::9683:c4ff:fe04:ddfc dev eth1 table local  metric 0 
local fe80::9683:c4ff:fe04:ddfc dev wlan1 table local  metric 0 
multicast ff00::/8 dev br-lan table local  metric 256 
multicast ff00::/8 dev wlan0 table local  metric 256 
multicast ff00::/8 dev eth1 table local  metric 256 
multicast ff00::/8 dev wlan1 table local  metric 256 
0:	from all lookup local 
32766:	from all lookup main 
4200000001:	from all iif lo lookup unspec 12
4200000003:	from all iif eth1 lookup unspec 12
4200000003:	from all iif eth1 lookup unspec 12
4200000009:	from all iif br-lan lookup unspec 12
lrwxrwxrwx    1 root     root            16 Jul 31 19:21 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            47 Aug  4 12:56 /tmp/resolv.conf
-rw-r--r--    1 root     root           127 Aug  4 13:05 /tmp/resolv.conf.d/resolv.conf.auto

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root           127 Aug  4 13:05 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1
nameserver ::1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error

==> /tmp/resolv.conf.d/resolv.conf.auto <==
# Interface lan
nameserver 208.67.222.123
nameserver 208.67.220.123
# Interface wan6
nameserver fe80::1614:59ff:fef7:3af0%eth1

The DNS should be in wan, not lan.

Remove the gateway from the lan, it must be in wan

There is a dns advertised in wan6. It could be answering first without the proper information. If you don't use ipv6 you can disable the wan6 interface.

1 Like

Now I can only browse with firefox that has a DNS configured in app. Other pcs are offline
The network is like that:
A - Internet provider router (wifi turned off)
B - GL.iNet GL-B1300 with OpenWrt 21.02-r4 connected via cable to the internet provider's router
C - Netgear Extender EX6150v2 with OpenWrt 19.07.7 connected via cable to B
The ip's actually are A) 192.168.1.1 B) 192.168.2.1 C) 192.168.2.10