Still on kernel 4.14.95 after upgrade on WRT3200ACM

I upgraded using the openwrt-18.06.4-mvebu-cortexa9-linksys-wrt3200acm-squashfs-sysupgrade.bin image and I am still on kernel 4.14.95 and this is causing kmod package dependency errors. Has anyone else encountered this issue where the kernel is still on the previous version, but everything else appears to have upgraded properly? I appreciate it!

Sounds really strange.

I tested the 18.06.4 sysupgrade file on my WRT3200ACM, and sysupgrade went quite normally. After reboot, the kernel related files are shown quite ok as 4.14.131

 OpenWrt 18.06.4, r7808-ef686b7292

root@router3:~#   opkg list-installed | grep "^k" | head
kernel - 4.14.131-1-994eede0975f460c1e52fa5947e65fc6
kmod-bluetooth - 4.14.131-1
kmod-btmrvl - 4.14.131-1
kmod-cfg80211 - 4.14.131+2017-11-01-10
kmod-crypto-acompress - 4.14.131-1
kmod-crypto-aead - 4.14.131-1
kmod-crypto-cmac - 4.14.131-1
kmod-crypto-ecb - 4.14.131-1
kmod-crypto-ecdh - 4.14.131-1
kmod-crypto-hash - 4.14.131-1

What does "uname -a" say for you?
Are you using anything non-vanilla settings? extroot?
(or have you tried to use opkg upgrade to upgrade packages?)

4.14.95 #0 SMP Mon Jan 28 08:54:32 2019 armv7l GNU/Linux

root@lawdawgs:~# opkg upgrade kmod-usb-core
Upgrading kmod-usb-core on root from 4.14.95-1 to 4.14.131-1...
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-core:
 * 	kernel (= 4.14.131-1-994eede0975f460c1e52fa5947e65fc6)

root@lawdawgs:~# opkg list-installed | grep "^k" | head
kernel - 4.14.95-1-8d45bc4124b425e568ca3ec03511914e
kmod-bluetooth - 4.14.95-1
kmod-btmrvl - 4.14.95-1
kmod-cfg80211 - 4.14.95+2017-11-01-9
kmod-crypto-acompress - 4.14.95-1
kmod-crypto-aead - 4.14.95-1
kmod-crypto-cmac - 4.14.95-1
kmod-crypto-ecb - 4.14.95-1
kmod-crypto-ecdh - 4.14.95-1
kmod-crypto-hash - 4.14.95-1

The only non-vanilla configurations I would have would be for packages like adblocking or dnscrypt, but I do not think this is what you mean.

BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 OpenWrt 18.06.4, r7808-ef686b7292

Based on that, your system has not been sysupgraded properly. The kernel is from January.

Using "opkg upgrade" that way for kernel modules is wrong, but that was hopefully just for testing purposes...

Have you used "opkg upgrade"? If yes, you may have upgraded the base-files package that includes the /etc/bannner file that you are showing above. So you might have newer versions of some files, but not of the kernel itself.

I think that you need to sysupgrade again.
(There is no way to upgrade kernel by itself.)

After the sysupgrade, please do not use "opkg upgrade". That is not the proper way to do version upgrades in OpenWrt.

1 Like

Update: I cleared the settings before I upgraded and this time it was successful. In the back of my head I knew I should have done this the first time, but maybe I will remember for the next update. I thank you!

Thanks! I had a feeling I would need to re-do the upgrade. I will experiment at a future time when no one needs the network. I appreciate the assistance!

1 Like