Status of WAC510 port

Flashed your build now. So far so good.


Can the factory image be flashed with the upgrade function of the original firmware?

To be honest, I never tried. So far I initially used the following installation method and then sysupgraded ever since:

Ok, I tried to flash the openwrt-ipq40xx-generic-netgear_wac510-squashfs-nand-factory.ubi via the web interface (original firmware) into a WAC505 - The original fw is always made for WAC510 and WAC505.
I put the root imgage into a tar archive with the following layout:

-rw-r--r-- root/root        14 2021-02-21 15:00 metadata.txt
-rw-r--r-- root/root        16 2021-02-21 15:00 version
-rw-r--r-- root/root   7864320 2021-02-18 17:32 wac5xx-ubifs-root.img
-rw-r--r-- root/root        56 2021-02-21 14:59 wac5xx-ubifs-root.md5sum

where metadata.txt is:

WAC505 WAC510

version (I choose the following):


the .md5sum file is the result of "md5sum wac5xx-ubifs-root.img > wac5xx-ubifs-root.md5sum"

The AP was accepting the layout and it seems flashing, but after 2 reboots it came back to the original firmware :frowning:

May be the WAC505 has some different layout (eg. it has only one LAN port).
Sadly, I have no serial access to see, what's going on.

It probably flashed, booted, failed, then booted to second partition which usually holds an older copy of the factory firmware.

I was told that you can only flash over a serial uart connection from factory.

1 Like

Just in case anyone else wants to use these things with VLANs, I'm using mine on tagged ports now, after following the guide I think @Gingernut tried to link to (this one).

Rebased @sumo's repo on master with no other patches. No issues with performance that I can see. Getting 300 something Mbit/sec with iperf3.

Speaking of your repo @sumo, did you get anywhere with creating a PR?

1 Like

No problems here to comment.

FWIW I have the lowest CPU frequency set @ 200Mhz as Qualcomm recommends and just recently enabled schedutil (replaces the old ondemand cpu governor), still testing but seems positive.

Schedutil needs enabling at compile time but here's what I stuff in my rc.local file:

# set CPU min freq scaling @ 200 MHz:
echo "200000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq

# switch the CPU scaling governor:
echo schedutil > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor

No, sorry. But I hope to be able to really tackle it over easter.

I just tried installing OpenWrt from the original factory Netgear firmware V5.0.10.2 (01/08/2019) and it worked just fine. The only thing I noticed is that while the Netgear firmware does allow its web configurator via WAN PoE port, OpenWrt defaults to using it as an actual WAN port NOT allowing LuCI access so one has to revert to using the LAN port (defaults to regular for LuCI access.

I re-based everything again and am now in the process of preparing the actual pull-request.

1 Like

Are you saying that you were able to flash from stock to OpenWRT using the factory.ubi image and directly from the Netgear webUI?

BTW anyone have any idea how to return to stock Netgear firmware from OpenWRT?

Yes, that is exactly what I'm saying.

1 Like

Well, so far I left an ancient Netgear installation on the backup partition of mine, so I was always able to go back by manually swapping primary/secondary as explained by others before.

1 Like

OK, I submitted my pull-request now. The commit message also contains all the collected lore plus whatever I validated concerning installation (from stock web UI or using TFTP) and dual image stuff. I also uploaded current images to my nextcloud for you to try (see Status of WAC510 port - #101 by sumo). Any feedback welcome. Thanks!

1 Like

As pointed out by Chunkeey in your PR, I compiled and flashed a build without the ipq-wifi-netgear_wac510 device package and using the upstreamed boardfiles and haven't encounted any wifi releated regressions and seems safe to remove it.

	DEVICE_DTS_CONFIG := config@5
	BLOCKSIZE := 128k
	PAGESIZE := 2048
	DEVICE_PACKAGES := uboot-envtools

As far as I remember the local BDFs are newer then upstream ones.
There was a update to one of the radios.

1 Like

Only found your original PR and when it was added upstream.

Were they extracted from a newer factory firmware?

edit: found an update but seems to be based on the same upstreamed version:

PR has been merged to master.


I build the firmware on my local build server to test it with my WAC505.
Sadly, I got the same result as before: The AP reboots 2 times and returns with the netgear firmware :frowning:

At the first reboot I see NO network activity for a longer time ( checked with
tcpdump -n -i eth1 'ether host 08:02:8e:41:f1:cf'
on my local machine, where it is conncted to)

The only difference between WAC510 and WAC505 are the number of ethernet ports. The WAC505 has only one ethernet port...

I got a TTL UART adapter but I don't have the "special screw driver thing" for the funny screws now - I try to get one and open the case to connect the serial port do debug the boot process, but that could take a while...

Any idea why the build doesn' run?