Static routing problem

Hi all,
this is my configuration,
image

my home subnet is 192.168.0.0.
Now, I'd like to communicate with 192.168.1.0.
In router 1 I set up the static route and in router 2 I installed OPENWRT.

In router 2 I have these settings:

Can anyone help me?

  • From where (I assume your statement means 192.168.0.0/24 is the SRC of your tests)?
  • Are you experiencing an issue doing so?

You never say. You'll need to provide more information on what you're testing.

The routes you made are not clear (e.g. your 192.168.1.0 route seems incorrect - which is why your test is likely not working, from your diagram, the interface is LAN), so I'll just suggest the following.

  • The Fritz needs two routes for: 192.168.1.0/24 via <lan> gw 192.168.10.4 and 192.168.0.0/24 via <lan> gw 192.168.10.4
  • :point_right: The C7 needs a route for 192.168.1.0/24 via <lan> gw 192.168.0.16

The corrected route for the C7 should fix your communication issue described in Post No. 1.

Yes the subnet 192.168.0.0/24 is the source of my tests...
I am not able to ping any device in subnet 192.168.1.0/24 from 192.168.0.0/24 and vice versa.
The C7 already has this route:
image

Are wrong the routes in Router 2?

1 Like

I apologize. I mistook "router 2" to be the C7. Router 2 doesn't need any static routes, the upstream default route will work. So any static routes added to Router 2 are incorrect.

You just need the following:

sorry but whydo I need to modify the fritz? it is in 192.168.10.0/24 subnet... I'm interested to .0.0 and .1.0...
many thanks for your reply

I understand.

If you're not concerned about the Fritz network(s) being able to reach the subnets, then just add the following:

Let us know your results.

from 192.168.0.0/24 I can ping 192.168.1.1 but not a laptop (192.168.1.179) connected to the .1.0 lan...

screen773

  • Is this the firewall config from the R2?
  • Since you allow WAN to LAN on R2, did you open the firewall on the host 192.168.1.179?
  • Is this new - that you're able to ping 192.168.1.1 (you don't say - can we see the C7 routes)?
  • Did you remove the static route in R2?
  • Do you have other 192.168.1.0/24 hosts to test?

I removed all static routes in R2.
This is the static route in R1:
image
How can I disable firewall for 192.168.1.179? If is it possible I would like to disable firewall at all...
same problem with another device (192.168.1.20) I can ping .1.20 from .1.179 but not from .0.0 subnet

This is is a screenshot of the middle C7, correct (apologies, the theme seems to be changing and there's no ID numbers or "Status" button on OpenWrt's theme)?

  • You would have to follow the instructions of your Operating System of your hosts. You can also test traceroute to the DST IPs
  • You'll need to answer the inquiry about the firewall (allowing WAN to LAN) on the last Archer C6 - it's not clear from the screeshots if you showed the Archer C6's firewall

This is the Archer C6, correct?

my 2nd and 3th reply are of R2

This is traceroute to 192.168.1.179:
image

1 Like

Thank for the clarity.

Please provide the results of a traceroute/mtr [*nix] or tracert [Windows] -

  • To: 192.168.1.179 and 192.168.1.20
  • From: 192.168.0.0/24 subnet

I see you provided a trace.

Also please answer:

Does your R1 (Archer C7) firewall permit forwarding on LAN [interfaces]?

On an OpenWrt - it looks like this:

screen774

Also verify after adding the C7 route:

R1 routes:

1 Like

TRaceroute to 192.168.1.20
image

1 Like

That's OK.

  • You'll need to verify the R1's firewall:

screen775

I think R1 has firewall disabled:

About nat e forwarding R1 has this options:
image