Static IP with PPPoE

There is another post were someone mentioned this and it turned into a crazy thread. Just search "Use a static IP address with PPPoE." Before anyone asks... Yes my ISP uses PPPoE, Yes I pay extra for the static ip service, Yes I've been using it for (7) years on Tomato on a Netgear R7000 and then a small dell optiplex with a dual Intel NIC card running PfSense.

I wanted something less error prone and quiet, so I bought an APU2 from PC Engines.
I set it up with openwrt-19.07.4-x86-64-combined-ext4 on a 30GB SSD. I tested the wireless modules and everything seemed great. I was ready to replace the PfSense box and when I set it up I realized there's no way to set any IP info if the connection is PPPoE. In PfSense I can add it in the configuration, like this:

Anyone know how I can set the static ip/subnet/gateway even if configured for PPPoE?
Thanks in advance.

Okay, there seems to be a fundamental misunderstanding about the nature of a PPPoE uplink. Let me try to put that into words, probably grossly oversimplified:

With a PPPoE connection, the "endpoint" of your IP does not lie with your router, but on the other side of the PPPoE tunnel, at your ISP. Your ISP decides which IP address to handle for you, based on his policy and your contract. He will then let you know, through PPPoE, what that IP is, so your router knows where to route packets. There is nothing to be gained from overriding the IP for a PPPoE connection, because it's not on your router's side, it's not your decision to make.


Thank you for that, I appreciate your fast reply. Except... If I don't enter an IP/Mask/Gateway along with the User/Pass, it will not connect. It is a static IP address. I was given all of that information by the ISP. I will try their support. Perhaps I need to use a static address.

Here's my current setup on PfSense and the mangled config (hope you can read it):

What does happen? The ISP is supposed to push your account's IP and other settings to your router as a standard part of PPP.

(Technically speaking, it's not a push. The router requests an obviously invalid IP (usually "") and the ISP answers with "nope, that's not it chief", and the correct IP. That's the "IPCP configuration requests" part of the PPPoE protocol.)

But yes, if this doesn't happen, it's a problem with the ISP's PPPoE setup. I'm not completely sure, I believe you can manually set the interface's IP after the fact, but that seems like a workaround. I would take this up with the ISP first before trying to fix their strangeness.

1 Like

I agree, unless someone is familiar with the exact settings required it's a bit pointless. For what it's worth the ISP is Asahinet in Tokyo. I will research the issue, call their customer service and review my logs.

Perhaps I need to set up a custom PPP connection.

That is curious, I never had any PPPoE issues with AsahiNet - username and password, and nothing else is required. I'm not on a static IP, but even with a static IP their settings guide do not require you to set an IP anywhere.

I'm thinking there's some issue somewhere else with your configuration. Are you absolutely positive you entered the correct PPPoE ("PAP/CHAP") credentials, what does the system log say about the PPPoE process? (Also, did you set the MTU to 1454 as they recommend? That tripped me up in the beginning, IIRC OpenWrt defaults to 1480, but that should not completely cripple your line.)

Edit: This is a working configuration of the WAN interface for AsahiNet, that's all that is required. It is a completely bog-standard PPPoE configuration, with the exception of a non-standard MTU value (eth0.2 is the WAN interface on my device, no idea what it is on an APU2):

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'pppoe'
	option username '(redacted)'
	option password '(redacted)'
	option keepalive '0'
	option mtu '1454'
1 Like

I just remembered: If you unplug your old router, and plug in your new one, AsahiNet will not accept PPPoE connections from the new router for (IIRC) something like 5 to 10 minutes. It is probably just some sort of timeout after the MAC address of the router changes.

I never looked deeper into it or even tried to counteract it (by cloning the MAC address) because I don't change devices that often and the problem goes away by itself fairly quickly.

But this may be your solution after all: just wait for a few minutes.

Thank you takimata san! Are you in Japan as well?

I know exactly what you're talking about. It should just be as simple as connecting with the right username/password (and in the case of asahinet, the MTU). I did those things and it still didn't work. I've been using them for almost 8 years now and this is my 4th router I've used with them with a static IP address. Each time there was some small weird thing that made the auth fail.

But you are right about the MAC address change and the 5-10 lockout! I went through that before and forgot about it! I have been swamped with work, but I should have time to try tomorrow. Also, their English support is pretty good, which is great because my Japanese is really terrible =(
Last time I had ipv6 issues (NTT has such a weird ipv6 implementation!) and they really helped me out. In the past, I always had to override the ip and gateway given by PPPoE for it to work, they even gave me those special instructions when I got the static IP. But it's possible I don't have to do that anymore.

I will let you know how it goes. Thank you for your help!

I have no idea why it didn't work before. I formatted the ssd and reloaded openWrt x86 to make sure everything was vanilla and it worked fine. Just username/password and the ISP hands me my static ip. No damn clue (I swear my first attempt was on a vanilla install also).

It still has a little hiccup on boot where the first connection attempt fails with an auth error, but if I reset it it connects. This happens on every reboot. So I need to find out how to make it auto retry or auto reset a certain number of times before quitting.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.