SSID not publishing (WiFi)

I have a mini PC with a WiFi and an Ethernet port.
I am trying to set it up as an AP (simplest case).
I have 2 radios (0 /1) and I have configured radio0 to the 2.4GHz band (default/auto).
Following the docs, I believe I have the setup correct ... but it doesn't work! :slight_smile:
/etc/config/network

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'

config device
        option name 'eth0'

config device
        option name 'wlan0'
        option ipv6 '0'

and /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'virtual/mac80211_hwsim/hwsim0'
        option country 'GB'
        option cell_density '0'
        option band '2g'
        option legacy_rates '1'
        option channel 'auto'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option key '******'
        option ssid 'LabNet2'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'virtual/mac80211_hwsim/hwsim1'
        option band '5g'
        option country 'GB'
        option cell_density '0'
        option channel 'auto'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'LabNet5'
        option encryption 'psk2'
        option key '******'
        option disabled '1'

The problem is that I cannot see the configured LabNet2 SSID from my phone/analyser - and running scan from the WebUI doesn't find my (seperate) router, which is on both bands.
I have tried various combinations of bands/channels/encryption to no avail.
I'm new to OpenWRT, but I think I understand what it's doing ... but obviously not well enough.

Please suggest anything I can do to determine the problem (or, preferably, fix it).

Many thanks

tim

yeah, there's only on radio hw out there, you did the right thing, by not to writing it out ...

virtual ?

Not sure about that one - it got put into the wireless file when I made it. I had to install

opkg install libnl
opkg install libnl-tiny
opkg install kmod-cfg80211
opkg install kmod-lib80211 
opkg install kmod-mac80211
opkg install kmod-mac80211-hwsim

and I assume the last is for the hardware simulation, so the single h/w device can be configured for both bands.

hwsim is only a purely virtual wireless card, unless you're doing development, you'll never need it - it's useless for the task you want to use it for.

Ah. I grabbed the above list from a dev post (with no knowledge of the packages at all).
I'll try with a fresh install (and w/out the hwsim).
Thx