SSH won't open!

Hello!
I'm new to OpenWRT and want to use the WRT firmware. I'm trying to change the firmware on my Xiaomi AC2100 R2100 router because I don't like the firmware from China! The procedure is very well explained on the OpenWRT website for this router.
The first time, I did everything right and managed to open SSH, but after the last instruction (store the firmware on the router) the power went out! After the debrick I was unable to access the router, but I managed to revert to stock firmware using the official Xiaomi repair tool. I tried again to change the firmware to OpenWRT. I did everything correctly, but when I went to the Prompt (I use Windows 10) to check SSH, this message came up saying it is blocked:

Question: Where am I going wrong and what is the procedure to update the firmware after receiving this message?

Edit the known_hosts file which is detailed in the error message and delete the line beginning "192.168.1.1".

Each time you reset a device to defaults, it generates a new host key and then the client will throw the error you see.

Thanks for your help! How should I proceed with the instructions on the website?

  1. get the stok string
  2. copy/paste the stok replace the <stok>
  3. then, copy/paste the 4 web info into an internet browser.
    the 1-3 links, return some errers, ignore it, continue...
  4. the last one need mods the old password / new password

finally, after get return = (code0), than you could use SSH to connect your router.

if you use ubuntu, add the following in ~/.ssh/config file:

 Host 192.168.31.1
    KexAlgorithms +diffie-hellman-group1-sha1

Steps 1, 2 and 3 => ok

So step 4 would be this? (New Password: XyZ)

http://192.168.31.1/cgi-bin/luci/;stok=/api/misystem/set_config_iotdev?bssid=Xiaomi&user_id=longdike&ssid=-h%3B%20echo%20-e%20'XyZ%5CnXyZ' %20%7C%20XyZ%20XyZ%3B

I did this before on my xiaomi-R3, likes this:

http://192.168.31.1/cgi-bin/luci/;stok=20a234eb589074330db500790c182822/api/xqsystem/set_name_password?oldPwd=12345678&newPwd=admin

not same as yours.

Thank you for your help! But I managed it this way:
ssh-keygen -R 192.168.31.1
removing the SSH entry for these IP

I entered SSH and did as indicated on the website. The steps were:

Was the OpenWRT firmware installed correctly?
What is the IP to access OpenWRT? Because 192.168.1.1 and 192.168.31.1 do not work.
NOTE: This Xiaomi AC2100 R2100 router is connected to another main Humax HGB10R-02 (now, I can't access it either!) I'm going to turn off and restart the routers and the computer...

Connect one of the LAN ports of the router only to your PC. Don't connect the router to any other network at this time. Also turn off the PC wifi for now. The Ethernet should obtain an IP address in the 192.168.1.X range from the router.

After doing the entire procedure for installing the OpenWRT firmware in this Xiaomi AC2100 R2100 router, should I leave the router on until the two blue lights lit? Or should I turn off the outlet as soon as the light blinks in orange?
Thanks!

Your router is flashed openwrt correctly.
Do not connect wan cable, you have to wait one blue led lit, then ~2min later, browser should see luci login page, at 192.168.1.1.
Or SSH root@192.168.1.1 should work.

Sorry, I don't think I know how to do the correct procedure. 192.168.1.1 is not included in the settings!

WRT

ip

you got SSH access! Run Cmds:

opkg update
opkg install luci

Then try the browser .

1 Like

You have installed a snapshot image. Read the link for instructions how to install Luci, which is not installed by default in snapshots.

https://openwrt.org/faq/can_not_connect_via_webbrowser

Yes!
SSH2

Thank you very much! It worked out.

Hugs

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.