Ssh root@ not connecting

I was looking into doing openwrt years ago, but never got into it. I recently installed 19-07 on my linksys wrt1900ac (I assume first gen as it doesn't state v1 or v1 on bottom) after I upgraded to the wrt 3200 couple weeks ago. I use it as backup to broadcast tether from iPad in event of local network outage and be able to connect my smart home devices and iPad had limit of 5 connections and I have 22 in home (couple Alexa, smart outlets, wifi Light switches) so it is set up as a passthrough router. I did setup using ethernet cable and can access luci in browser with

My problem is getting openvpn, mainly caused by not being able to ssh root@ as I keep getting ssh: connect to host port 22: connection timed out.

Using Git for windows on windows 8.1

Haven't fired up my linux machine in a few months, and haven't tried on girlfriends windows 10 machine (not a fan of 10)

I haven't used linux command in over a year, so I'm extremely foggy in the use, but I know I'm connected to my device as I'm running luci aat same time as running Git.

Can I get some advice please?

you have transposed the first two numbers, try


Try (I am assuming you swapped the 192 and 168 in your actual connection attempts, rather than just in this post).

EDIT: I see that @dlakelan beat me to the punch :slight_smile:

1 Like

ssh root@openwrt.lan should also work in a default installation.

Do you still need to telnet in on first install to set the root PW, and then reboot to allow SSHD to start?

I don't know. I followed these steps to get started and after a day of using and my local network was working again, I just used switch on back of router to turn off. After a week off i was looking into doing ipvanish on it, but my subscription has ended and it required me to flash DD-WRT which I don't have to if I just do openVPN on openWRT. After first setup and setting password, I haven't done anything to it.

1 Like

Sounds like you set a password, and it should be working. See if it's listening on Port 22 (Use nmap or something to scan it)

Do you have the Luci web gui installed? Of so, you can use that to pull the configurations and check the ssh config to see if the port had been changed accidentally or something.

Others above have already mentioned that you have used the wrong IP for connecting via ssh.
What happens if you try with the correct IP (see above)?

1 Like

Telnet has been completely removed. New versions of OpenWrt accept SSH from the start. The password is null, you do not need a password. If you have set a password in the GUI use that password also for SSH.


@dlakelan I did. I have it right in web browser, but wrong in Git and my post here. Just got home from work and noticed. I'm in. Heading out of house again and will try openVPN when I get back. Thank you.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.