SSH not working after upgrading to 19.07.5 (non-default shell )

I was running 19.07.3 on my router, and I could easily ssh into the box using an SSH key. Now I upgraded to 19.07.5 and SSH is not working any more, neither using password authentication, nor using an SSH key.

I tried removing the package dropbear, deleting the provided public key, reinstalling dropbear, letting opk overwrite any existing file. Then I added a complete new dropbear instance, choosing password authentication and allowing root to login using password. Then I even changed root's password to "123456" temporarily, to eliminate any typing errors.

But still no deal:

ssh root@
root@'s password: 
Connection to closed.

What is wrong in 19.07.5, compared to 19.07.3? Why does this dropbear version not accept any connection?

Once I accidentally hit ENTER without typing in the password, which leads to this dialog:

ssh root@
root@'s password: 
Permission denied, please try again.

So, typing in the password is closing the connection, while typing in no password is answered by "permission denied".

Can someone explain this?

1 Like

You are not using a custom login shell, are you?

Check the logs.


Both of my devices still have SSH access available after upgrading to 19.07.5, with the same configuration as before.

Append -vv to the ssh command, it might reveal more. Be careful, it might contain a hash of your key in the output, if you use one.

YES, YES, YES! Silly me!

I forgot to install bash after upgrading.

Boing! (That was the sound of my head hitting the table...)

Sorry for the unnecessary disturbance!


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.