SQM won’t automatically start after boot

Continuing the discussion from Luci-app-sqm won't automatically start after boot:
Still the issue in OpenWrt 23.05.2, r23630-842932a63d

Adding this to /etc/init.d/sqm SQM is enabled in boot:

    procd_add_reload_trigger 'firewall' #<addthis
	procd_add_reload_trigger "sqm"

I think this can happen if during start up any init script running before the firewall or sqm script errors out...