SQM: per-host isolation question

I enabled per-host isolation but I'm not sure I've done it right.
These are my sqm settings:

config queue 'eth1'
	option debug_logging '0'
	option verbosity '5'
	option linklayer 'ethernet'
	option overhead '22'
	option interface 'eth0.2'
	option download '60000'
	option qdisc 'cake'
	option script 'piece_of_cake.qos'
	option upload '6000'
	option qdisc_advanced '1'
	option squash_dscp '1'
	option squash_ingress '1'
	option ingress_ecn 'ECN'
	option egress_ecn 'NOECN'
	option qdisc_really_really_advanced '1'
	option iqdisc_opts 'nat dual-dsthost'
	option eqdisc_opts 'nat dual-srchost'
	option enabled '1'

My main concern is about whether I should state nat dual-dsthost or nat dual-dsthost ingress, as I've seen in some other threads.
The same goes for nat dual-srchost.

So this really depens on where eth0.2 is facing towards. Your current config will equalize incoming (ingress) packets by their destination (dst) IP address after NAT, and outgoing packets (egress) by their source (src) IP address after NAT. If eth0.2 is your WAN interface than this will make sure all active internal IP addresses will share the available capacity equitably. If however eth0.2 points into your LAN you will share capacity equitably between external IP addresses...

Just post the output of ifstatus wan | grep -e device to confirm whether or not eth0.2 is your WAN interface....

I believe it is, since I have the modem in bridge mode.
Besides, WAN shows an external IP in Luci -> Network -> Interfaces, which I believe confirms it.

root@OpenWrt:~# ifstatus wan | grep -e device
	"l3_device": "eth0.2",
	"device": "eth0.2",

EDIT: The router is a Tp-Link Archer C7

Yes, so your configuration should result in fair/equitable sharing between all internal hosts. Does this match in what you see? E.g. run concurrent speedtests on two different computers and look how much bandwidth each gets...
I would recommend a longer running data transfer for that purpose, like Belwue's:

time wget -O /dev/null http://speedtest.belwue.net/10G --report-speed=bits 

I guess so, since so far none of the connected devices seemed to suffer from lack of bandwidth.

Thanks. I had two linux devices downloading that 10G file simultaneously, and also turned on a Netflix stream.
Netflix worked as expected, and it showed bandwidth usage of 6 Mbps
The two Belwue's flows were downloading but with download speed floating highly.
I ran this for about 4 minutes.

In summary, it seems to be working as expected, I guess.

EDIT: Out of curiosity, and in case it might interest someone, a 24-hour monitoring window, where the test above shows clearly as pointed by the arrow:

(I don't know the forum policy regarding image uploads, so I'm sorry if I'm infringing some rule, just let me know)