SQM not working in wwan (wireless client)

This is tested on a newly installed lede on a wireless router (miwifi-mini).

The sqm worked fine when the wireless router is connected using lan cable on the wan port to a 4g modem.
In this scenario, I have selected wan(eth0.2) in the sqm.
I have set the download/upload limit.
The sqm is configured with Cake and Piece of Cake.
When I ran speedtest, it showed slightly below the limit. (OK!)

I need the wireless router to be connected wirelessly to the 4g modem.
This time, I have selected Radio1 (2.4ghz) and used the wifi scan to connect to a 4g modem.
I have also ticked replace existing wifi configuration.
Radio0 (5ghz) is not configured.
Once done with the setup, I have selected wwan(radio1) in the sqm.
When I ran speedtest, it went over the limit. (Not OK!)
Is there anything wrong with this configuration?
Is it not possible on wwan?

I read that I can use the sqm on lan.
In this scenario, I have selected br-lan(eth0.1).
I have reversed the download/upload limit.
It worked fine when I ran speedtest.
I would like to go few steps ahead.
I would like to use Layer Cake.
When I ran tc -s qdisc, I can see diffserv3 on the download (lan egress) instead of upload (lan ingress).
Is this correct?
I would also like to enable per host isolation.
Do I need to reverse these on lan?
For ingress queueing disciplines: nat dual-dsthost
For egress queueing disciplines: nat dual-srchost

Thank you.