Spring Framework Spring4Shell (CVE-2022-22965)

Hi there!
Just running a Nessus sacn over my router (https://openwrt.org/toh/tp-link/archer_c20_v5), it founded this vulnerability:
"##### Description

The remote host contains a Spring Framework library version that is prior to 5.2.20 or 5.3.x prior to 5.3.18. It is, therefore, affected by a remote code execution vulnerability:

  • A Spring MVC or Spring WebFlux application running on JDK 9+ may be vulnerable to remote code execution (RCE) via data binding. The specific exploit requires the application to run on Tomcat as a WAR deployment. If the application is deployed as a Spring Boot executable jar, i.e. the default, it is not vulnerable to the exploit. However, the nature of the vulnerability is more general, and there may be other ways to exploit it.
  • These are the prerequisites for the exploit:
  • JDK 9 or higher
  • Apache Tomcat as the Servlet container
  • Packaged as WAR
  • spring-webmvc or spring-webflux dependency
Solution

Upgrade to Spring Framework version 5.2.20 or 5.3.18 or later.

See Also

http://www.nessus.org/u?718f9ac3"
Thanks for reviewing!
KR

False positive, neither JAVA nor tomcat are available for OpenWrt at all.

1 Like