Sporadic unable to obtain IP address on AP with VLANs

I am trying to setup an AP with different VLANs mapped to SSIDs.
The setup is as follows:
VLAN 3 - untagged to WAN
VLAN 10 - tagged to WAN
VLAN20 - tagged to WAN

I have added the WAN port to the br-lan bridge as I am just using this as an AP.
I have added each of the bridges to their own wifi network.

When connecting to the network sometimes it gets stuck obtaining an IP address, and other times it will successfully connect.
What is interesting is that it only happens when I am connecting to the network that is bridged with VLAN3. It does not happen with 10 or 20 (which are tagged).

So that leads me to think there might be something going on with the untagged vlan.

Here is my network config file:

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option packet_steering '1'
    option ula_prefix 'fda7:186d:74b5::/48'

config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'lan1'
    list ports 'lan2'
    list ports 'lan3'
    list ports 'wan'

config device
    option name 'lan1'
    option macaddr '32:9d:b1:1c:fc:0f'

config device
    option name 'lan2'
    option macaddr '32:9d:b1:1c:fc:0f'

config device
    option name 'lan3'
    option macaddr '32:9d:b1:1c:fc:0f'

config interface 'lan'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.1.5'
    option gateway '192.168.1.1'
    list dns '192.168.1.1'
    option device 'br-lan.3'

config device
    option name 'wan'
    option macaddr '32:9d:b1:1c:fc:0e'

config bridge-vlan
    option device 'br-lan'
    option vlan '3'
    list ports 'lan1:u*'
    list ports 'lan2:u*'
    list ports 'lan3:u*'
    list ports 'wan:u*'

config bridge-vlan
    option device 'br-lan'
    option vlan '10'
    list ports 'wan:t'

config bridge-vlan
    option device 'br-lan'
    option vlan '20'
    list ports 'wan:t'

config interface 'IOT'
    option proto 'none'
    option device 'br-lan.10'

config interface 'GUEST'
    option proto 'none'
    option device 'br-lan.20'

Your help is highly appreciated, Thank you!

You can quickly cross that out by using tagged frames on vlan 3 on the wan port.

Sorry for the late reply. I tried that and now it seems to be working. Still a head scratcher why it wouldn't work untagged though :thinking:

Tagged and untagged on the same port doesn't always work. It's not something that has been heavily tested in DSA development on these consumer-grade switch chips. It should be avoided when possible.

1 Like

Understood, thank you!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.