Sporadic internet connectivity issues

Hello everyone, I have an issue that is making me want to pull my hair out.
I'm on the verge of calling Spectrum (my ISP) to have them look into it, but wanted to check here first.
Details as follows:
The Problem:
Sometimes websites become unreachable through the web, or take an extremely long time to load the initial request (20+ seconds).
Services I am running drop off the internet several times a day/week with no pattern.(This is found from notifications that they are offline)
Strange behavior on web services I use day to day like netflix, hulu, and facebook, for example:
Sometimes discord is unable to stream video as I talk to others.
Sometimes Websites stop working as I'm talking to people over discord. The internet remains connected, but some IP's just seem unreachable.

This started randomly around November 23rd with no Configuration Changes.

What I've done:
Factory reset Modem/Router.
Changed DNS servers.
Turned ISP DNS servers on/off.
Manually gave clients DNS server addresses to use.
Rested dnsmasq/network/ odhcpd
Restart Router (This works for a random amount of time from minutes to hours)
Upgraded Openwrt Firmware versions from 18.xx to 21.02
Checked memory/ram usage on the router to make sure it's regular.
Tried various fixes posted by similar issues on the forum.

Screenshot(my section):
Top Left console:
Output of a tracert for facebboks IP (one that wasn't working at the time) from a client computer VPNed into my home network.
Bottom Left console:
Ping of Reddit and Google to show differences of websites as one works and the other doesn't.
Top Right Console:
Traceroute of reddit.com (one that wasn't working at the time from the web) from the router.
Bottom Right:
Traceroute of facebook.com (one that wasn't working at the time from the web) via IPv6 from my router.

On the very right is a screen shot of my neighbors:
These come from a neighbor friend with the same ISP on her client computer who doesn't have internet issues.
The top part is a tracert of facebook.com iIPv6
The bottompart is a tracert of facebook.com IPV4

Restarting the router fixes these issues for a random amount of time, from minutes to hours.

Observations:
System Log/Kernel Log do not indicate any issues while the problem is happening or look any different when they do work.

Equipment:
Router: Linksys WRT1900ACS
Modem: Motorola MB8600 DOCSIS 3.1
Firmware: OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.295.67054-13df80d
Attached below is my dhcp, dhcp-opkg, network config files.


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	list ra_flags 'none'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'
config dnsmasq
	option domainneeded	1
	option boguspriv	1
	option filterwin2k	0  # enable for dial on demand
	option localise_queries	1
	option rebind_protection 1  # disable if upstream must serve RFC1918 addresses
	option rebind_localhost 1  # enable for RBL checking and similar services
	#list rebind_domain example.lan  # whitelist RFC1918 responses for domains
	option local	'/lan/'
	option domain	'lan'
	option expandhosts	1
	option nonegcache	0
	option authoritative	1
	option readethers	1
	option leasefile	'/tmp/dhcp.leases'
	option resolvfile	'/tmp/resolv.conf.d/resolv.conf.auto'
	#list server		'/mycompany.local/1.2.3.4'
	option nonwildcard	1 # bind to & keep track of interfaces
	#list interface		br-lan
	#list notinterface	lo
	#list bogusnxdomain     '64.94.110.11'
	option localservice	1  # disable to allow DNS requests from non-local subnets
	option ednspacket_max	1232

config dhcp lan
	option interface	lan
	option start 	100
	option limit	150
	option leasetime	12h

config dhcp wan
	option interface	wan
	option ignore	1


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdf7:1919:dc8a::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr 'c6:41:1e:34:60:9b'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option type 'bridge'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option dns '2606:4700:4700::1111 2606:4700:4700::1001'
	option peerdns '1'


Edit
One more strange issue.
My friend hosted a web server. Several other people could connect to it, but I could not. I could fine when tethering internet from my cellphone. So just for giggles, I tried connecting to a VPN via mullvad VPN from my desktop. I was then able to connect to my friends webserver. But when not connected to the VPN, I got no response. This is also in the category of *it fixes itself for a while after a router reboot and then stops working again *

Cross-posted on reddit...

1 Like

Does the problem only affect the internet connectivity, or do you have difficulty with internal connections (i.e. ping tests to another host on your LAN)? Does this happen for wired devices only? wireless? or both?

Oh nice. Yeah I didn't know which would be the better platform for support.
The DOCSIS I have is a bridged only modem, as it has no routing capabilities.

I used to have the router itself hosting Adguard home for DNS.
But when issues started happening, I reset it and tried a raspi running pihole.
After I still had issues, I reset the router once more and just let the ISP hand out DNS to the router and router take it from there.

I have not noticed any issues with internal connections at all. Both wired and wireless seem to be affected by this as well.

If your internal network is working fine while the outages happen, I'd start by looking at your modem's status/statistics page. On my Arris cable modem, I can get that info by simply going to 192.168.100.1 -- not sure if it will be the same address on yours or not.

To understand more of the connectivity issues, you can run concurrent continuous pings to the following:

  • another device on your LAN
  • the router (192.168.1.1)
  • the cable modem (192.168.100.1 or whatever your modem uses)
  • a public IP like 8.8.8.8

By looking at patterns from those ping tests, you should be able to begin to understand what might be at fault (an internal network issue, the router, the modem, or upstream from the modem).

That's fine.

Whenever you cross-post, it's considered a courtesy to include the link(s) to the other site(s) you've posted the issue on.

It helps eliminate confusion, and wasting other people's time researching and suggesting things that have already been done.

1 Like

Interesting enough, I'm unable to reach my modem behind my router at all.
(Could this because it is in bridged mode?)
My router is showing it's gateway is 192.181.96.1.
I've tried pinging it,192.168.100.1, and accessing it from several places including the router to no avail.

Assuming that you made a typo here and that it was actually 192.168.96.1, that is probably the modem's address. That said, it would also probably be the case that your modem is not actually bridged. You'll know this for certain if the address on your WAN is 192.168.ccc.ddd where the last 2 octets can really be anything.

Please double check that gateway address and look at your WAN's IP.

No Typo. This is actually my routers Gateway.
My public ipV4 is in range 192.181.113.x
The modem is in Bridged mode as the Motorola MB8600 is a "bridged only modem". It has no other capabilities. It's just a bridge Modem.
Attached is a before and after tracert from not working to router reboot working.

Ok. Just was worth checking.

With respect to trace route - while it is a useful tool, pings are better suited to testing intermittent connectivity issues.

When it works, the pings return fine. When it doesn't, they don't at all.
It will stop working several hours out of the day usually off and on for hours at a time for different websites.

I was hoping someone could gather some clues or detail from the tracert as it shows more information about the packet in transit and where it may be getting held up, or maybe see the differences in the path when working/not working.
As you can tell from the screenshot, at one point I could ping one website fine, and the other not at all. That strikes me as really odd.

Is that true for all pings (another host on the local network, router, and a public IP address)? That is the information I am suggesting you capture either simultaneous persistent pings.

I'll give it a try and report back tomorrow evening. If my memory serves me correctly, once a website is down for one client, it will be down for all.

To be able to do this you need to define an interface on the correct physical device (same as the wan interface, no worries you can configure and use multiple interfaces on devices). This would need to be configured with a static address of 192.168.100.2 and included in the same firewall zone a wan.
Mind you it has ben ages since I tried that on DOCSIS, but use this routinely to access my bridged DSL-modem.

In my experience, this should ‘just work’ without the need to create additional interfaces or routes. This is true for dhcp based connections, and assumes that the router isn’t configured to drop all rfc1918 packets before they hit the wan interface.

For dsl (pppoe) connections, it does appear that it is necessary to create an additional interface to access the upstream modem. But since the op is using a cable modem with dhcp, I’m pretty sure this is not the issue.

Possible, I just vaguely remembered the steps I had to take a decade ago ;)...


So I filled this out.
I dont see anything on 192.168.100.1, thr luci interface is on 192.168.100.2.
Do these settings look correct?
I didn't quite understand what you meant about the firewall.

As I said previously (and your mileage may vary), I have never needed to setup an interface like that in order to reach the cable modem's status interface.

My guess is that the specific modem you are using may use a different address, although I can't really guess what it is. When I attempted to do a general search for this information, I couldn't find much in the way of authoritative answers -- some sources confirmed my guess of 192.168.100.1 while others had different addresses, and I wasn't convinced about quality of each of those sites.

I would recommend that you contact Spectrum and ask them if they know the address for that modem's status page. It is in their best interest for you to have access to it so that you can rule in/out the connection between their equipment and your cable modem as the issue. You typically can't configure anything on a DOCSIS modem, so it's not like you can mess anything up. Hopefully Spectrum will have this info and be willing to share it with you.

I think DOCSIS standards propose or even mandate 192.168.100.1 so there is little slack for an operator that wants to stay compliant to the standards...