Some sites not working on my router because it switches to an IPv4 address

I'm still a bit new on OpenWRT and networking in general, so please be gentle!

So here's the setup: I have an OpenWRT router ( connected to our ISP's router ( via a wireless client mode connection. IPv4 sites work, but I can't connect to IPv6 sites. This was fine for me for months, but IPv4 has been down on our ISP for a couple of days now, so I was forced so finally set up IPv6 on the OpenWRT router. I followed this guide and it worked, but here's the problem:

When I'm connected to our main router, I can access all sites. Facebook, Discord, all of those. When I'm connected to the OpenWRT router, however, only websites running IPv6-only work. I can open Facebook, Google, YouTube and a handful of sites, but other sites like Discord don't work.

What's weird is that when I try to ping Discord on our main router, I'm pinging an IPv6 address. When I switch to the OpenWRT router, I'm pinging an IPv4 address. And since IPv4 is down here, it doesn't work.

How do I fix this? TIA!

@NotShige, welcome to the community!


  • Does your router have an IPv6 address?
  • Is there a reason you're not using the /6 argument?
1 Like

Which router? On our ISP router, it's getting both an IPv6 and v4 address. But, when running tracert on an IPv4 site, it just fails on the sixth hop, which should indicate that it's an ISP problem. It also sometimes just doesn't give us an IPv4 address on reboot. That's why I'm trying to get this work.

On my OpenWRT router, it's getting both an IPv6 and an IPv4 address.

I have no idea what that is. I'm sorry.

Yes, as it's obvious the ISP router has IPV6, as you have connectivity.



  • Make sure this LAN interface config says /64 (64) and not disabled:
  • Does your Windows machine actually obtain Public IPv6 address?
1 Like

Oh, /6 for pinging! The result is the same regardless on the main router. It successfully pings the site. On the OpenWRT router, it just says Ping request could not find host Please check the name and try again.

Looks like it was on /60 by default. Some sites are still not working though when I changed it and after rebooting.

Yes, it does.'s working now?

What sites?

If the same Discord, it's not really clear to simply say working/some.

1 Like

Run this:
And this for good measure:

  • I'm particularly interested in DNS and any failures.
  • I'm least interested to hear comparisons to the "main router" - so long as we confirm the OpenWrt is getting a prefix and IPv6 address, I'm getting really confused about troubleshooting connectivity on the OpenWrt
  • Please clarify if you are stating the test machine had IPv6 address while plugged into the OpenWrt LAN only
  • Please clearly describe the change you observed after changing to /64 and rebooting
1 Like

Still yes and no. As I've said, some sites still aren't working.

Discord, Reddit, and other sites. Also Minecraft doesn't work because they use IPv4-only. I've looked up these websites and it seems that they're still running on IPv4. Maybe this is some NAT problem, I'm guessing? Because why does Discord and Reddit open when I'm connected on my main router but not on my OpenWRT router, despite being IPv4 sites?

IPv4 is down on our area, yeah, but why do they work when I'm connected to the main router, is what I mean to fix.

Doesn't work. Took too long to respond, is what it says on Chrome.

Yes, it has an IPv6 address and yes, it's the only device plugged in to the LAN port.

Here's the results when I'm connected to our main, for good measure.

Nothing. I can only still connect to IPv6 sites.


Ummmm...Your picture on the "main router" shows that to be untrue.

Can I ask...other than the trace...why are you under the impression IPv4 is out?

If you made no IPv4 changes to the OpenWrt and you don't have a LAN network IP match on the IPs router and OpenWrt LAN (meaning both improperly configured as, I think a call to your ISP is in order.

1 Like

Not really... It does say that I have a public IPv4 address, but it also shows on the image that I have no access to IPv4. Weird...

This is our ISP router at the moment. Notice the Unspecified on the IPv4 Address.

Yup, both have different subnets...

Yeah... that seems to be the solution right now lol. Thanks for the help, though!

Also, additional info. Looks like our entire neighborhood is down. I was asking my folks here since we're on the same ISP. I connected to their Wi-Fi and we all had the same problem. Heh.

I'll update when it gets sorted out, I guess.

EDIT: One call later and it's fixed now!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.