Some i211 weirdness

Recently, I was asked to repurpose a Sophos XG 106 device (Intel Atom E3930 processor, 4 GB RAM, 64 GB SSD, Intel i211 NIC). A lot of people probably already know where this is going... :smile: OpenWrt installed with no problem, but the behavior of the NIC was bizarre; it was detected by the OS, it could negotiate links (at least the indicator lights looked like links are being negotiated), but no actual data transfer would occur. I tried installing pfSense, but the NIC behavior was the same under that system.

So far, I am not telling anyone anything new; the i211 is a known pain in the behind. But then it occurred to me that OPNsense just put out a brand-spanking-new release 23. So on a whim, I installed it, and... (drum roll...) everything Just Worked™.

So... did I just get lucky or has some unsung hero upstream ironed out some of the i211 kinks, and it first propagated into FreeBSD 13 and OPNsense 23, and will eventually come to Linux and, by extension, to OpenWrt? Any informed guesses would be sincerely appreciated.

Did you test OpenWrt snapshot (kernel v5.15) or a general purpose linux (e.g. Debian/ bookworm) with kernel v6.1 (not necessarily as router, just enough to test all ethernet ports)? If either of those work, chances would be good.

No (the XG 106, now running OPNsense, is back with its owner), but I like the sound of "chances would be good"... :smile:

Well, I211 by itself wouldn't be bad news to begin with…

Host/Kernel/OS "gateprotect" running Linux 5.15.86 x86_64 [ OpenWrt SNAPSHOT r21727-3c31f6b521 ]
System         R & S Cybersecurity gateprotect GmbH GP-7543
CPU Info       4x Intel Celeron J1900 @ 1024 KB cache flags( sse3 ht nx lm vmx ) clocked at [ 1332.800 MHz ]
Videocard      Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display  tty resolution (  )
Network cards  4x Intel I211 Gigabit Network Connection, at ports: d000 c000 b000 a000 
Processes 124 | Uptime 37days | Memory 97.8/3832.5MB | HDD 32GB SATA Flash Size 32GB (0%used)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.