Some devices won't connect to 2.4Ghz wifi

Hello,

I have a really weird issue, I have 3 access points flashed with OpenWrt supporting both 2.4 and 5GHZ.
I'm running v 22.03.3(latest at the moment). But last week I noticed and today I notices again, that some devices refuse to connect to 2.4Ghz.
Last week I disabled 5Ghz and my Iphone13 wouldn't connect to 2.4Ghz.
and today I tried to setup a wireless bridge(also using OpenWrt ) but it wouldn't make connection at all.
it was until I remembered the issue last week that I decided to build the bridge only using 5Ghz which works ok.
Next to that I have a camera probably facing the same issue, because I can't connect it to the wifi and this one only supports 2.4Ghz so 5 is not an option.

I have plenty of devices only supporting 2.4Ghz which are connected without any issues at all. So I was wondering if I could maybe debug something or find something in the debug log?

First, access your device via SSH (See how: https://openwrt.org/docs/guide-quick-start/sshadministration)

Then please copy the output of the following commands and post it here using the "Preformatted text </> " button.

Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Alternatively:

ubus call system board;
uci export network; uci export wireless;
uci export dhcp; uci export firewall

Also, is it only some devices that are not able to connect to 2.4 GHz, whereas others CAN do it?

hereby the output of the files

 -----------------------------------------------------
 OpenWrt 22.03.3, r20028-43d71ad93e
 -----------------------------------------------------
root@OpenWrt4:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix '<Some ipv6 address>'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '3 5 0t'

root@OpenWrt4:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
        option channel '44'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '<SSID>'
        option encryption 'sae-mixed'
        option key '<Password>'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'platform/ahb/18100000.wmac'
        option channel '10'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '<SSID>'
        option key '<password>'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'
        option ieee80211w '0'
        option encryption 'sae-mixed'
        option disassoc_low_ack '0'

root@OpenWrt4:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt4:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp

only some devices are not able to connect to 2.4 Ghz but actually all devices I tried connecting in the last week.
I have about 40 2.4Ghz only devices which all work without any issues. (except from the camera mentioned above)

        option encryption 'sae-mixed'

hmm have you tried different encryption method?

1 Like

sorry for the late response, I needed a moment to check this where no one needed internet.
So I updated everything to v23.02.4 .
and downgraded security to WPS-PSK,
that actually was a 2 step thing, so in the meanwhile my laptop lost connection and I needed to attach the cable to click save and apply for the 2nd time?
strangly enough,
my esphome devices(all on wifi) kept communicating with Home assistant.

but after downgrading, My Iphone said "password incorrect", where with "sea-mixed" it says unable to connect.
So still not working, but a different message. I still don't know why

wpa is not considered secure anymore and Apple considers it a legacy protocol. https://support.apple.com/en-gb/guide/security/sec8a67fa93d/web

wpa2 should be the bare minimum. Apple advises to transition to wpa3 where possible.

With regard to OpenWrt, I personally have not had problems with wpa2 (and my android device), but I have read some forum posts that claimed mixed mode sometimes causes trouble. I am also not sure if the wpa3 functionality is working flawlessly yet either, so wpa2 would be a safe bet. Try that. Try all of them :smiley:

I tried WPA2 on 2.4Ghz, and all 3 devices which couldn't connect earlier can connect now.
This includes an OpenWrt bridge, so somewhere also OpenWrt handles this different.
unfortunately I cannot use WPA3 only as not all my devices support this.

on 5Ghz, I'm still using mixed mode and there are no issues with it at all, also not for the devices which couldn't connect on 2.4Ghz, so maybe the 5Ghz specs ore drivers are somehow different.

Anyway this fixes my issues thanks.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.