Some apple devices unable to connect to 5GHz networks after period of time

Model: TPLINK Archer C7 v2
Firmware Version: OpenWrt SNAPSHOT r9992-86fd8cb / LuCI Master (f138fc93)
Kernel Version: 4.14.118

When my device is newly booted up, all devices I have are able to connect to either WiFi network, however something happens over time and eventually my Macbook Pro, iPhone, and iPad (and maybe also my Vizio TV) are unable t connect to the 5GHz network where my Android device works without issues.

Has anyone experienced this? How would I go about trying to debug this?

My /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option country 'AU'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid '5ghz ssid'
	option encryption 'psk2'
	option network 'lan'
	option key 'pw'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/ahb/ahb:apb/18100000.wmac'
	option htmode 'HT20'
	option country 'AU'
	option legacy_rates '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid '2-4ghz ssid'
	option encryption 'psk2'
	option key 'pw'
	option network 'lan'

on 5g... how come?

That is....an excellent question. It's curious that this checkbox is shown on the tab when looking at the settings for the 5GHz network. Here's the 'Advanced Settings' tab:

Edit: I've disabled it, but nothing really changed. Android can still connect to 5GHz but seemingly nothing else can.

Just a few ideas:

  • Change SSID to something that is 1 word
  • Use only Upper, lower letters and numbers in the passkey.
  • Lower htmode to VHT40
1 Like

Please provide logs which are showing this problem.

1 Like

Tested version 4.14.115 : 5Ghz big problems with Wr1200JS & Xaomi R3G

I have recompiled an old version 4.14.102 and fine …

Hey @tmomas does the default logging level on the OpenWrt satisfy this? When looking at the System Logs I don't see anything really happening of note. Only that devices are connecting and nothing else.

Is there a better way to get logs out?

Did you test with Apple devices? What were the problems you encountered?

There are no spaces in the SSID, just upper and lower case characters (I just changed it for posting publicly here).

Only using lowercase characters with a length of 18 characters total.

I understand that this lowers the channel bandwidth to 40MHz versus 80MHz, do you know if Apple or older WiFi clients have trouble connecting when using 80 vs 40?

This post over at Ubiquiti seems to indicate older Mac devices have issues connecting on the 80MHz channels on their APs.

But also seems that people have things work better when switching to 80MHz

Anyway, found this post, decided to switch my AC Pro to ht80 and like a miracle all problems on Apple devices disappeared, speed tests are well over 200’s Mbps, no more image loading issues in any of the apps.

Futher, Apple's own website seems to claim that 80MHz should be fine as long as interference isn't an issue:

no problem with vht80+iphones over here

Apple devices seem to behave a bit different(ly) than others. Make sure you're not drawing false conclusions from what you see.

They want to be able to ICMP ECHO aka ping (at least some of the) network components which DHCP tells them to use. I'm not sure whether it's the gateway or the DNS server or both.

In some way, they seem to assess connectivity of an available SSID in this way.

I think if it's the only option they have, they'll still connect after some delay, so they may appear to stick to one freq band of one AP.

We have an iPhone that doesn't seem to like 2.4 GHz channels (tried 2 different routers, stock and custom firmware, different channels, still not good, even when is couple of meters away. And then by potting it on the 5 GHz band of the same router, it just worked!

It seems like the only way to properly test this would be to monitor your interface with wireguard on the apple device it self and then determine if it got satisfactory responses back from the pings?

The discussion you refer to is not very helpful. People mix up HT80 and VHT80 and almost nobody -- and in particular the OP -- is specific about whether there was a real connectivity problem or the devices just wouldn't connect.

802.11ac devices must support 80 MHz wide channels, but also 40 MHz wide channels. However, in a dual band setup, STAs have the choice which band they will connect to.

This choice is not part of the silicon and is implemented in different ways. From what I observe, STAs make suboptimal choices based on rules of thumb. Often, they will prefer 2.4 GHz due to signal strenght unless one taks care of that, even if 5 Ghz might have the potential for higher data rates. On the other hand, I have a Windows notebook with a Broadcom chipset where I can set several roaming parameters including preferred band, 2.4 or 5 GHz.

What you see is that your Apple WiFi STAs only connect to your AP directly after your AP booted, but not later?

Is your OpenWRT C7 running as a router or as an access point?

How is your DNS configured for those STAs?

Why are you running that snapshot? Have you tried other OpenWRT versions with your C7?

I have an Archer C7 v2 as well. I have had the same issues with apple devices - they would connect fine initially then fall off the network. I solved it by replacing the 'ath10k-firmware-qc988x-ct' firmware with 'ath10k-firmware-qc988x' firmware in the build config. No issues since.

The problems for me started when the default firmware changed to the candela tech firmware back in Dec.

@greearb do you have any idea?

Long ago I worked on some power-save issues that happened with specific mac-books and our wave-1 firmware, but I fixed that problem. It was due to some funky power-save interaction with the macbook. Probably to debug this I would need to get one of the apple devices that has the issue and debug it in detail. Anyone have such a device they would like to loan me?

Sorry, no spare devices to help out, but happy to run any diagnostics if you need me too.

I was seeing it on an iPad air 2 and an iphone xs. Normally would take a number of hours after connecting before dropping off the network. The devices still looked connected but had no communication and the AP showed no devices associated with the 5GHz radios. Nothing in the logs either.

The android and windows devices in the house had no issues.

I'll also add that it has been a few months since I reverted the firmware. You may have made changes to the CT firmware since.

Does the iPhone "dislike" 2.4 GHz or is it completely unable to connect? Which model is it?

Were the routers really technically different? Which router models did you try?