[SOLVED] WLAN problem in connection with iPhone


I am desperate with the following problem. I have the OpenWRT main router QNAP QHORA-301w on one floor and a Netgear WAX 206 as AP on another floor.

There is no problem with all the devices in the house, but there is with the only iPhone that we have. The iPhone has no problems with the Netgear. It connects and you can surf in the browser. When the iPhone connects to the QNAP, the connection works, but no pages are loaded in the browser. Nothing simply happens. However, if the iPhone connects to the guest network on the QNAP, it works also there. I have no idea what the problem could be, it would be great if anyone had any tips or could help me.

Can you help out with some diagram on how it all is connected, in the meantime veryfying /etc/config/wireless has identical connection parameter sets.
Likely check that you obey Apple's guidelines (they are reasonable baseline)


Look for differences in configurations between the two. If guest works, something is different.

Thank you both for your answers. I didn't find any differences quickly. I will continue tomorrow my search and will also read the information from this apple link.

If you don't figure it out, post these next visit:

1 Like

Sorry for my late answer. Do you need realy all of them config files? I will send it but are there some things in the files that I should make unrecognizable? At least the WLAN passwords, I think. Is there anything else that should not be shared with the whole Internet? Devices, IP's? Thanks for your help

Yes, anything that might identify you such as MAC addresses, public ip, passwords, SSID. But just redact them, leave the field. e.g password "redacted".

I don't need all of them; they are just the configs we start looking at.

And now I'm sorry; I did not see your reply because you did not reply to me but to the thread.

1 Like

I update now from OpenWRT 23.05.2 to 23.05.3 and it worked now.
The iPhone has not received any updates recently. Strange but it seems that the problem has been solved. Thanks for your time though.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.