[Solved] WiFi interface disappears after 'wifi up' command

Hi everyone!
I got some problem with WiFi configuration. I have Mikrotik RBM33G with Atheros AR5b225 on it. WiFi device works fine. It perfectly works as AP and WiFi client via hostapd and iw. But when I configure this with 'wifi config' command wlan0 disappears from network links list after 'wifi up' command. Only `echo 1 > /sys/bus/pci/rescan' returns it back.

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '5'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        option disabled '0'
        option country 'RU'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'MyNET'
        option encryption 'none'

Can anyone help me?

Have you tried instead:

/etc/init.d/network reload
/etc/init.d/network restart

Thank you for your reply
Yes, I did, got the same result

Unless I'm very mistaken, Atheros AR5b225 is ath5k based - which doesn't support any HT modes to begin with (remove the setting).

1 Like

Yes! Now it works! Thank you slh!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.