[Solved] Wi-Fi issue with WRT 1200AC after update to 18.06

Hi all,

I have been experiencing strange WiFi behavior since yesterday and I have now done some experiments to nail down the problem.

Problem description:
I have two WiFis, 1x 5ghz and 1x 2.4ghz. All devices use the 5ghz, only my printer relies on the 2.4ghz.
I updated last weekend and have had no problems until yesterday - at some point I was not able to visit the embedded web server (EWS) of my printer anymore. I experienced weird behavior in LuCI to, I often had to press menu items twice on my phone. At night, things then became even worse, I could not reset my router to 'vanilla 18.06' anymore.
So I flashed the sysupgrade image from 18.06, which worked fine.

Now the observation: if I start from a fresh image and activate my 2.4 GHz network only, I can reach my printer. If I put it to a cable, I can reach it too.
If I connect to the 5ghz network with any other device and start browsing the internet, the 2.4 GHz connection becomes "crippled". There is no indication of this, the speeds still show 30-72MB but I simply can't reach the printer and it does not get properly discovered from my laptop (the CUPS webinterface at one point found it but only after several tries). From time to time the printer spits out pages which were tried to be printed several hours ago. If I connect to that 2.4ghz network with my laptop and try to access LuCI, I experience a very slow build up of the interface, so the speeds must be very slow.

I have no idea what this could be. Any ideas? Is there a bug in the driver?

Try updating the WiFi drivers using

I have 1200ac myself but I don't use 2.4. Stock 18.06 is working pretty good for me.

Has the general directions

Has the specific filenames you want.

Thanks for the suggestion. I just "downgraded" to and restarted the router.
So far it seems to work - I will be back here if there is more trouble.

Thanks a lot for this!

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You can also mark the reply that solved your problem:

It's not formally solved yet - I updated this morning over my breakfast coffee (6am in Germany :wink:) so I want to see whether it's actually changed and the problem is gone.
I'll mark it as solved then of course once I'm confident that this solved the issue actually.

EDIT: So far no outages and I can't indicate anything pointing towards a not-solved. Thus solved. Thanks for the nice support, that was really frustrating :slight_smile:

1 Like

So this indicates a more recent mwlwifi should be cherry-picked to the anticipated 18.06.1?

Who knows. I'm not aware of any other post that described a similar problem in that combination - might have been just me?

My comment was based on this thread and the open issue.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.