[SOLVED] Where is the install from Comfast E110Nv2? Only upgrade?

I only see the upgrade's left in the list and the install image is gone.

I had to go back to OEM firmware via TFTP after a upgrade to 19.07. the image was corrupt or so, because the update didn't went thru.

Anyhow. Where can I find the Install image of OpenWRT for the Comfast E110Nv2?

Looks like it has only the sysupgrade image (as also the OEM firmware is based on OpenWrt), but it also needs specific flashing process to reset settings. Read from the commit adding support for Comfast E110N


1 Like

Thx Buddy,

So To make it clear for myself and so I do not make the same mistake again.

  • I download the sys upgrade and flash it into the OEM Firmware as an upgrade.
  • Then when the device starts up I press the reset button several times, till it blinks fast
  • Then I can use OpenWRT 19.07?

am I right?

Many thanks for your help buddy.

No experience with the device, but the core of that commit message is that the OEM firmware settings may survive, as the original firmware is an OpenWrt variant.

Resetting the router via button, from LuCI menu or with "firstboot" on console should be enough.

Hi Hnyman,

Thanks for your message.

Unfortunately, this was not the solution. I had taken the firmware and implemented it. However, I didn't get any errors or anything like that, but the modem stopped responding and got into a BootLoop. Because of this I had to start a TFTP connection again and put the OEM version of Comfast on it. (For the people who have the same problem, the modem loops on ask for file "firmware_auto.bin". But implement it on ip this seemed to work for me, I had to try couple of times but after a while he took the image and rebooted back.)

Then I went back and found out that everything worked when I was running on version 18.06.2. However, not version CF-E110n but CF-E320N uploaded it and I immediately received the OpenWRT back.

So this topic is solved and I hope to have helped several people with this in the future.

The correct file:

cf-e320n-v2-squashfs-sysupgrade.bin 48ac55f7d3b9217883e1303e783628e283d70fbd9d5c3fc580ec1678d1aac225 3712.0 KB Tue Jun 25 16:11:37 2019

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.