[Solved] Where is MPD player?

I have Asus WL-500GL Premium V2 router. I have installed new LEDE but I don't found MPD player on the list. MPC is present but MPD isn't.

MPD is the player daemon. Does the WL-500GL offer audio connections? Without that, it doesn't make much sense to run mpd on the device.

1 Like

Look for packages mpd-full and mpd-mini. You may also need mpd-avahi-service to announce it. As @darksky mentioned, you will need to attach a USB sound card to your router to play sound.

What are you trying to do, I mean... exactly?

MPD "players" (clients is a more valid word) are useful when you want to access the connected USB sound card and the audio files, from a regular computer running Windows/Linux/OS X/Whatever.

If you just want to play audio files/streams from the router's CLI, there is no need for MPD as you can use an app like mpg123 or madplay combined with wget (attached image follows as an example).


In few words... besides a USB sound card and the nessesary packages installed, you don't need MPD to play audio files.

If you want to achieve something else that requires MPD, please define what so we can help you further.

Thank you for reply. I have installed the package mpg123. Work, but sometimes I hear knocking in the speaker. I used before the router as a WIFI internet radio and I had installed openwrt with mpd, mpc and other necessary packages. It worked very well. With the LEDE, mpg123, alsa installed I hear crackling in the speaker and the audition isn't good. Sometimes I get the error, something related to alsa. Before I was able to configure mpd with vi /etc/mpd.conf. In LEDE is there any possibility of configuring audio? I don't know how to configure alsa. I don't have a client for mpg123. Before I had mpd, mpc and on the computer or the smartphone I had installed droidmpd, auremo or ario. In LEDE I found the client mpc but I have not found the mpd package. Do you have any suggestions?

It seems that mpd* packages haven't been compiled for the mipsel_mips32 platform, in all 17.x releases.

They should be under the "packages" folder, but they are not.

I don't think that installing packages from 15.05.1 will work (you can try it anyway), so it's better to go back to Chaos Calmer, at least for now.

A report would also be useful but I'm not sure where to (report it).

Given that CC was using uclibc, while anything newer than that has switched to musl as libc, there isn't a fighting chance for those old binaries to work.

Thank you all and like angelos said back to Chaos Calmer is the best solution. The LEDE is not now the best solution for old routers.