[Solved] WDS Client stops passing traffic on EA8300 with recent 19.07 snapshot builds

I have an EA8300. I had a rocky start, but once that was dealt with, it was solid running a snapshot build from ~ June 16.

A week or so ago I decided to try a pre-release 19.07-Snapshot (first r10269, then r10287) and ever since then it's been having problems.

The EA8300 has a WDS client connection to my main router on Channel 36, using using radio2, which I have dedicated to that use. The WDS connection repeatedly stops passing traffic. It will work for a while after restarting the interface, but it inevitably dies again. Sometimes it will work for tens of minutes, or more, other times it dies in less than five. Power-cycling the whole router has similar results.

  • Traffic doesn't start flowing again without some intervention.
  • Client connections on the other 5Ghz radio continue working and the WDS connection itself remains established.
  • There are no other nearby access points on channel 36 to cause interference or airtime contention.
  • Neither the system nor kernel logs on both the EA8300 and my main router show no anomalies before or during an outage.
  • I don't think it is related to the amount of traffic over the link. It seems to happen even when there is only idle background traffic from one or two client devices.
  • It may happen more often with two active clients on the other 5Ghz radio than with a single active client.

If the buildbot doesn't cough up a properly functioning build soon I'm going to revert to the older, build from June that was working for me. I'm hoping though that this is something that can be remedied before the release of 19.07.

Might try the -ct-htt firmware.

Thanks. I haven't had a chance to try the alternative firmware. Problem is still there with yesterday's 19.07 snapshot.

In the meantime, I wonder, other than dmesg and the system log, is there anything else I can check for hints on what might be going wrong?

Queue status, driver states?



I pushed updates for ath10k-ct today to 19.07.
You might want to give it a try?



Good to know! I'll install it once there is a .bin available on the download server.

If my problem isn't solved, it seems to have improved greatly. I'm not sure what did the trick, though. I've installed a number of new builds in the past couple of weeks, only to have the problem reoccur.

I think the solution may have come on the other end of the link. I started to suspect my c2600 was part of the problem and that it had something to do with 18.06.04, which I'd installed within a week or so of the time I started trying 19.07 snapshots on my ea8300.

So, I started installing 19.07 snapshots on the c2600, too. At first it didn't seem to make any difference, but about a week ago things got better with a new c2600 build, even while waiting for the bots to get around to the ea8300.

I wish I had something more definitive to report, but I'm glad things seem to have improved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.