[solved] VGV7510KW22 (o2 6431) - no VDSL connection

I have installed 17.01.1 and get the following output out of DSL event pipe on trying a VDSL (O2 - propably using Telekom network) connection (I've never used the box yet):

sEventType=DSL_EVENT_S_AUTOBOOT_STATUS nStatus=2 nFirmwareRequestType=0
sEventType=DSL_EVENT_S_LINE_STATE nLineState=00000100
sEventType=DSL_EVENT_S_LINE_STATE nLineState=00000100
sEventType=DSL_EVENT_S_LINE_STATE nLineState=00000200
sEventType=DSL_EVENT_S_LINE_STATE nLineState=00000300
sEventType=DSL_EVENT_S_LINE_STATE nLineState=00000380
sEventType=DSL_EVENT_S_SYSTEM_INTERFACE_STATUS nTcLayer=2 nEfmTcConfigUs=0x00000000 nEfmTcConfigDs=0x00000000 nSystemIf=3
sEventType=DSL_EVENT_S_LINE_STATE nLineState=00000001
sEventType=DSL_EVENT_S_LINE_STATE nLineState=00000000
sEventType=DSL_EVENT_S_AUTOBOOT_STATUS nStatus=3 nFirmwareRequestType=3
sEventType=DSL_EVENT_S_LINE_STATE nLineState=000000FF
sEventType=DSL_EVENT_S_AUTOBOOT_STATUS nStatus=2 nFirmwareRequestType=0

Last config settings are:

config dsl 'dsl'
option annex 'b'
option xfer_mode 'ptm'

Use your Provider Vectoring ?
you should know that the VDSL-Firmware inside LEDE do not support vectoring.
I guess that the reason are: The versions with vectoring support are not allowed to redistribuable.
But it is possible to extract a firmware with vectoring support from an other Firmware image see here:

I 've tried also which is labled being "VDSL over ISDN incl. vectoring support" but same result.

Your configuration looks good should working on VDSL
Try an Annex B Firmware. I think a best choice is a Firmware from a Telekom device.

Same with 5.7.6.A.0.7-5.7.1.C.0.2

Unfortunately my issue hasn't changed yet. Maybe a HW fault? A FRITZ!Box identified the line as VDSL2 17a (ITU G.993.2).

By the way I've found dozens of variants for the DSL configuration but after looking into current dsl_control script only annex setting has to be set explicitly ...

config dsl 'dsl'
        option annex 'b'

... everything else defaults to VDSL in it.

Also it's sufficient having default firmware packages dsl-vrx200-firmware-xdsl-a and dsl-vrx200-firmware-xdsl-b-patch. Installing the counterparts dsl-vrx200-firmware-xdsl-b / dsl-vrx200-firmware-xdsl-a-patch as well turns the patch mechanism to save flash memory (generating lantiq-vrx200-b.bin from lantiq-vrx200-a.bin or vis-a-vis respectively) upside down.

1 Like

Sorry @gho i have no idea.
Your config should work.
I have the same VDSL parameter but i can almost do what want and i get evrytime a connection.

No common issue - have got another box and this one connected immediately.