SOLVED: USB drive installation / block mount

Continuing the discussion from SOLVED: Simple USB Stick Installation Instructions for LEDE:

clicking the link opens an OpenWRT page that says this topic does not exist.

I believe the proper link is now https://openwrt.org/docs/guide-user/storage/usb-drives-quickstart

Thnx, jeff.

root@c7main:~# uci set fstab.@mount[0].enabled='1' && uci set fstab.@global[0].c
heck_fs='1' && uci commit
root@c7main:~# service fstab start && service fstab enable
this file has been obsoleted. please call "/sbin/block mount" directly

how do I call it directly?

#!/bin/sh /etc/rc.common
# (C) 2013 openwrt.org

START=40

boot() {
        /sbin/block mount
}

start() {
        echo "this file has been obsoleted. please call \"/sbin/block mount\" directly"
}

stop() {
        /sbin/block umount
}

Looks like it's just complaining that you explicitly called start

write
/sbin/block mount

and press enter. This mounts all mount points specified in the fstab, right now.

I've fixed the tutorial now to do that instead of calling service fstab start.