[Solved] Upgrading TP-Link Archer C20 AC750 v1 from development snapshot


I have a TP-Link Archer C20 AC750 v1 where I installed a development snapshot (the device wasn't yet supported at that time). Now I want to install the "official" firmware (18.06.1) but I have no idea how to do that. I've tried to download the sysupgrade.bin file but I get:

"The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

How can I do this? Do I need to go back to the factory FW and do a new installation?

Thanks in advance for any help.

First off, I'm not sure why you would get a message like that. Maybe because the kernel partition on your snapshot firmware is already larger than the one in the 18.06.1 image (kernel 4.14 needs more space than 4.9). I'd double check that first before proceeding.

If everything is OK, you'd need to use sysupgrade -F on the firmware image. That would perform a clean flash (ie wipe your settings). Since you're going 'back' to an older version of OpenWrt, that's the sanest thing to do. No need to flash manufacturer supplied images first; you're just hopping between different OpenWrt versions.

That being said, if all goes well somewhere at the end of the year (or beginning of next year) master should be branched in preparation for a 19.01 release. So if your present firmware runs fine, save yourself the hassle of going back to 18.06.1 and wait till 19.01 snapshots appear, and grab one of these.

Thank you for your quick reply. So, first thing is that I don't think I'm "going back" to 18.06.1 -- I believe the image I've on my device is older than the 18.06.1 release. File /etc/openwrt_version contains "r5201-8b9cdeb" and uname -r returns "4.9.58".

However, you refer to kernel partitions... If I do a 'df -h' I get:

Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.0M      2.0M         0 100% /rom
tmpfs                    29.5M    568.0K     28.9M   2% /tmp
/dev/mtdblock4            4.3M      1.2M      3.2M  27% /overlay
overlayfs:/overlay        4.3M      1.2M      3.2M  27% /
tmpfs                   512.0K         0    512.0K   0% /dev

Since the sysupgrade.bin file has 3.8M, maybe the issue is space? I've tried to use a USB stick but looks like there isn't support for mounting an external disk (I don't see a usb_storage driver anywhere in /lib/modules).

It look like you have at least 8 MB of flash, so that file size shouldn't be a problem. 4.9.58 sounds old indeed, the 18.06.1 tree is now at 4.9.137 :slight_smile: .

It looks like you should be OK using -F.

Awesome, thanks a lot! I've done that and it looks like everything is working great now with the new 18.06.1. Thanks!

If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

Done! And again, thanks!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.