[SOLVED] Trouble with new usb hdd's

so today i got my new 2x 4tb usb hdds in the mail wanting to upgrade my btrfs raid1 to a raid10 setup. However openwrt wont detect the new drives as hard disks.

i unplugged all other drives and only inserted 1 of the new drives, but still its not being detected as a hard disk. It does show up in lsusb tho.

Here are dmesg lsusb and fdisk -l:

thanks for any help!

  • Are they formatted with a particular filesystem?
  • If so, did you install that kmods into OpenWrt?
  • Are they USB 3.0?
  • If so, does your device have a USB 3.0 port?

they are formatted in ext4 and connected to a usb3 port

It's usually because kmod-usb-storage-uas isn't installed. If that's not it then try https://openwrt.org/docs/guide-user/storage/usb-installing

Maybe kmod-usb-dwc2 and kmod-usb-dwc3 should also be added to the list of drivers to try.

1 Like

Both are installed and up to date

Installing kmod-usb-storage-uas seems to have fixed it! Thanks for your help!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.