[Solved] Trouble setting up WiFi Access Point (DumbAP)

I am trying to configure my router to act as a WiFi access point for my wired network. The network consists of a modem, a router (PC running pfsense), and a few unmanaged switches.

The router I'm using to run LEDE is a TP-Link AC1750 v3.0. I have loaded 17.01.4, and updated all packages on the device. I used the following image to upgrade from openwrt:

https://downloads.lede-project.org/releases/17.01.4/targets/ar71xx/generic/lede-17.01.4-ar71xx-generic-archer-c7-v2-squashfs-sysupgrade.bin

Afterwards I had to go into fail-safe mode, as I could not gain root access. Once there I decided to reset to default by performing mount_root and firstboot.

I edited the /etc/config/network file, and deleted all configuration in /etc/config/dhcp. Additionally I disabled dnsmasq, odhcpd, and firewall:

/etc/init.d/firewall disable
/etc/init.d/dnsmasq disable
/etc/init.d/odhcpd disable

Here is my network config:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'ffff:ffff:ffff::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0 eth1'
	option proto 'static'
	option ipaddr '192.168.1.2'
	option netmask '255.255.255.0'
  option dns '192.168.1.1'
  option gateway '192.168.1.1'
  option hostname 'essos'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4 5 6'

/etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:01/0000:01:00.0'
	option htmode 'VHT80'
	option txpower '23'
	option country 'US'

config wifi-iface
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option ssid 'Not my real SSID'
	option key 'Not my real password'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/qca955x_wmac'
	option htmode 'HT20'
	option channel '10'
	option txpower '23'
	option country 'US'

config wifi-iface
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option ssid 'Not my real SSID'
	option key 'Not my real password'

My wired router is at ip address 192.168.1.1. It is configured as a dhcp server with a pool from 192.168.1.100 - 192.168.1.199. I have a static IP address setup for the access point at 192.168.1.2.

Whenever I plug the LEDE router into the wired network, it seems to break everything. I cannot reach any other devices from my desktop, including the wired router or the internet. When I unplug the LEDE router, the network returns to normal.

Is the lede box advertising that ipv6 ULA prefix? Perhaps that has something to do with it? Just a guess

This mite help.
https://lauri.võsandi.com/2017/01/reconfiguring-openwrt-as-dummy-ap.html
After installing OpenWrt on TP-Link WDR3600/4300 or Archer C7 following script can be used to convert the machine to a dummy access point which does not serve DHCP, but just bridges wireless and wired ports on the device.

Something must of changed in the later builds of LEDE /OpenWRT as that script don't work like it did. I just tride it out and had to go through and undo it all by hand after as opkg would not work.

I have an Archer C7 V2 running as an AP and my network config looks like this:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.77.2'
        option dns '192.168.77.1'
        option gateway '192.168.77.1'
        option ifname 'eth0'
        option igmp_snooping '1'
        option multicast_querier '1'

config interface 'lan6'
        option proto 'dhcpv6'
        option ifname '@lan'
        option reqprefix 'no'
        option peerdns '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 5 6 0'

Now, the only thing that looks different (and meaningful) to me is the option ifname where you provided both eth0 and eth1, while I put just eth0 because after reconfiguring the switch layout there is no distinction between WAN and LAN anymore, so I assumed there would be no eth1 anymore. This works for me. I can log in via SSH, all my wifi clients get internet. When I log in over SSH I use a wired connection. I never tried that over wifi, but I assume it would work as well. You don't need the lan6 section, obviously, if you don't want your AP to get an IPv6 address.

I also noticed your config has some lines with different indentation than the others. Maybe that causes issues when the configuration is processed? Just a wild guess. Or was that a copy&paste issue?

The indentation differences were due to how I posted the file and didn't exist in the file itself.

I changed my file to reflect yours (i.e. remove eth1 from the config interface 'lan' section) and it worked without issue.

Thanks!