[Solved] Trouble creating a non wired wireless extender on Plusnet Hub One

Hi, for the past few weeks I have been pulling my hair out regarding setting up 2 Plusnet Hub One routers running on OpenWRT.

The Main one, which I will just call 'router' is setup with VDSL input and Wifi and Wired LAN running. Wifi is on fast roaming which seems to be working for connections.

The Second one, which I will call 'repeater' is setup as a client to connect to the first on the 5GHz range and then repeat a 2.4GHz repeater to my wireless smart devices that only support 2.4GHz.

I have installed and setup relayd also, I have disabled dnsmasq and firewall in the repeater and I have a pi-hole acting as a DHCP server to supply the network with ad free connectivity.

Once I setup relayd and do a reboot on the repeater, my Glassware software on my laptop starts noticing lots of ARP changes on my network, all my devices now get the MAC addresses of the wireless devices on my repeater, this kills my network and I loose all connectivity. I have to reset everything after powering off the repeater.

Each time I get this far I have to reset the repeater to defaults, ssh back in and install luci and setup from scratch each time. I am now feeling a bit like a mad man doing the same thing over and over and it is not working. I must be doing something wrong as it all seems like it should be working.

Can anyone help point me in the right direction? Many thanks.

fwiw, refer to section 9.10 of the installation guide for HHt5a for using relayd on HH5a.


Works with LEDE 17.01, OpenWrt 18.06 and probably 19.07. Not tested it myself with 21.02.

Someone will correct me if I'm wrong, or explain it better, but I vaguely recall relayd config won't pass the original MAC address of the device through the bridge. Relayd is a 'fudged' solution, it's not like a regular 'repeater'.

1 Like

That's a good shout, thanks. I have read over it and I am 99% sure I have found an issue with my IP configuration on the relayd interface, I think my IP does not match the interface I want to bridge it to.

I will give it a try right now and report back soon.

I can now get connectivity using 9.10 instructions via LAN cable only. The 2.4GHz still has nothing. I think I am trying to do something that the Atheros chip drivers do not support. I believe I will have to hard wire or possibly use WDS in 9.14 instead. I will have a play about and see if I can get any further using the manual.

Did you factory reset the HH5a?

Assuming relayd is using 5 GHz for connecting to your primary router.

Is remaining unused 2.4 GHz wireless interface bridged to LAN ?

1 Like

relayd should be avoided, if possible, it has way too many issues (IPv6 doesn't work at all). The better solution (if all APs are running OpenWrt) is WDS/ 4addr.

1 Like

I have it working! I had tried WDS before I resorted to relayd without success, I was still trying to bridge wifi and lan together. Now I have just one selection as it says for just LAN and not WWAN also.

My outside wifi lights that didn't reach my main router now connect flawlessly.

Thank you guys for your help!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.