[SOLVED] Tplink mr6400 - 3g/4g sim interface


I installed the firmware also i installed Luci. I went to Interface and i find "LAN", "WAN" and "WAN6".

I plugged my sim to the router sim card slot. The question how to configure it?

I clicked on edit "WAN" interface. I had the bellow:

config interface 'wan'
	option proto '3g'
	option device '/dev/ttyUSB0' 
	option service 'evdo'
	option apn 'APN-ADAATCS'
	option ipv6 'auto'

I don't know if the device is correct but i had to choose this because of my option ifname was before 'usb0'
This modem come with a sim card slot. I don't have password for APN or nothing. But it seems it is not connecting.

I am not sure about the mr6400 but I have been using LEDE on the mr200 and the modem interface (original TP-Link interface even after flashing LEDE) is on Installing LEDE on the router does not affect the original modem interface.
mr6400's modem's web interface is available at with the default username/password of admin/admin.
from https://openwrt.org/toh/tp-link/tp-link_tl-mr6400_v1.0?s[]=mr6400

The idea i tried to login to the web interface but it didn't work. Should i use ip to my network so i can access ? Because i tried to ping and i tried to login with no success.

Yes, you might have to do this from a device with an IP address in the same range such as
I found that on the mr200 I had to use the full url including the "/login.html" to access it. Did you use that - exactly "" for your mr6400?

At first the default ip of the modem is so i used tftpd to flash it. so i installed Firmware OpenWrt Install. It worked after that i tried to login to “” for your mr6400 but didn't work. Should i put anything through putty? Did i miss something? is the default ip of the router when LEDE/openwrt has been installed. You do not need to change that unless you want it to be accessible from an ip address range that your other devices might already be set up to use. is the default login page for the modem - The included modem in this device that is running it's own Android OS as the openwrt page on the mr6400 states "this device has a hidden (disabled in the stock firmware) web interface. At least in LEDE, the hidden web interface is re-activated again on each boot and can be used to setup the 3g/lte connection after switching to LEDE. Modem's web interface is available at with the default username/password of admin/admin."

I think that you are getting confused between the two different devices in the mr6400 one being the router which now has LEDE/openwrt installed and is accessible via and the modem which is still an android device which has a web interface available on To access this modem web interface you should try from a device connected by a cable to a LAN port on the router (at least until wifi has been enabled). Presumably the router will have a route to the modem on as traffic will have to be sent through to the modem to reach the internet once the modem has been configured to use your SIM and internet provider.

I must admit that this did initially confuse me when I was configuring my mr200 so I can understand if you are confused as well. Once I understood this I could access the modem web interface on its own ip address using the url and access the LEDE/LUCI interface on so I am assuming that this should be quite similar on the mr6400 but using the url and access the LEDE/LUCI interface on

added by edit - maybe you still have to install LEDE if you have an old version of openwrt on the router currently. That's what I also had to do after installing openwrt on the mr200.

That what i did :slight_smile: anyway this configuration is correct?

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fdec:3135:d3f1::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1 eth1'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'

config interface 'wan'
	option ifname 'usb0'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'usb0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 0t'

It worked now. I had to leave my ip as dhcp.

If your question is solved, you can mark the topic as [Solved].

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.