[SOLVED!][TP-Link Archer C50] Could not upgrade to LEDE from OpenWrt due to the image file not fitting in the flash memory

After following the instructions on this topic I successfully installed this OpenWrt firmware, but when trying to perform an upgrade to the latest LEDE release (actually, any LEDE release) using LuCI, this message shows up after selecting the sysupgrade image: "It appears that you are trying to flash an image that does not fit into the flash memory, please verify the image file!".


I would like to know if anyone succeeded in upgrading to LEDE using the officially provided sysupgrade images or if it is safe to proceed with the installation even with the image size mismatch...

Maybe free up some memory first? Maybe remove unused pkgs? I would not tempt the fates as the warning seems clear enough.

Now I wonder why there's no sha256sum???

I also questioned myself about the absence of the SHA256, but I "manually" verified the sha256sum of the files and they match the ones provided here

About freeing up some memory, I don't think that is the case. I have already plenty of free space and I believe the "7.62MB available" message refers to the total space of the flash and not the free space. (also uninstalling and installing new packages do not change this value...)

So, I tried the factory.bin image in LuCI (don't proceed to flashing tho) and the image appears to match exactly the available flash space of 7.62MB:


Comparing the size of the two images (the sysupgrade and the factory ones) I see that they differ in only 0.2KB in size.

I know the factory.bin images are supposed to be used for "upgrading" to LEDE from the stock firmware, but it could be flashed from OpenWrt?

Thanks in advance for anyone who give me some light with this matter...

LEDE and OpenWrt both use the sysupgrade images, you can switch from one to the other with those (LEDE is extending the sysupgrade format a bit with the introduction of metadata, but you can still install an old (no-metadata) OpenWrt image from LEDE by overriding the metadata check; tge reverse works without nagging).

Ok. I understand that. What I do not understand is in which instance this is related with my size mismatch problem... =P Am I missing something?

And I'm trying to upgrade from OpenWrt to LEDE and not the other way around (what I think probably wouldn't be a issue do to the reduced image size of the first in comparison to the second).

So, for some reason, the LEDE sysupgrade image for the version 17.01.4 is much smaller than the previous ones, with a size of approximately 3,5MB (less than half o_O).

It was just a question of flashing the image from LuCI and I am now running the latest release os LEDE =D

Consider the problem of this thread solved!

Probably some features got removed from the default config for that device since the size was becoming critical.